incoming call problem

Discussion in '3CX Phone System - General' started by godiz, Sep 7, 2007.

  1. godiz

    Joined:
    Sep 7, 2007
    Messages:
    4
    Likes Received:
    0
    hi

    i have installed the 3cx free edition for evaluating purpose. i set up everything, that i can phone within my network (soft and hard phones) i also can call to an outside phone number over sipcall.ch. but i cannot receive phone calls from outside. when i try to phone with a normal phone i cannot hear anything through the phone. after a while the hungs up.
    i tried to chek the sipcall.ch settings with a softphone not over 3cx. i could receive the calls from outside without problems.

    can somebody help my, what i have to do?

    i already started from the beginng a severla times. in the server log, there is no incoming phone call registered. the line is registered to the sipcall.ch and all the clients too. i tried to set up the whole thing on a different pc, but the same problem (i tried a win2003 and a xp). i opened on my firewall the ports 9000 to 9499 as well.

    thanks for any hints. kind regards
    simon
     
  2. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Make sure you are registering using a properly resolved public IP. i.e. Is the STUN working ?

    You can see a Server Status line like this on startup:

    00:00:00.000 StunClient::process [CM115002] STUN resolved external IP=*.*.*.*:5060 by server *.*.*.*

    When the voip provider receives a call to your phone number it will issue a SIP INVITE to the listed address. It is then up to you NAT device to forward it directly (if this happens you will see a log entry i.e. incomming call in the Server status page).
     
  3. godiz

    Joined:
    Sep 7, 2007
    Messages:
    4
    Likes Received:
    0
    thanks for your answer

    i have the following stun entry in the "server status":
    06:42:42.250 StunClient::process [CM115002] STUN resolved external IP=62.302.111.89:13127 by server 65.64.78.23
    06:42:42.046 StunClient::process [CM115002] STUN resolved external IP=62.302.111.89:13127 by server 65.64.78.23

    does this seem to be ok?

    i have routet the nat (SUA only) in my zyxel firewall for Start port: 9000 end port: 9499 to 192.168.1.45 (internal pc with 3cx)

    no changes. incoming phone calls are not arriving in the 3cx phone server.
    i don't know what to do next.

    thanks for helping, simon
     
  4. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Hi simon,

    Your logs detail this; "IP=*.*.*.*:13127 ". Have a look at that port number.

    Your PBX is trying to use port 5060 but the firewall translates this port to something higher (13127). The resulting effect is that the PBX registers against the voip provider with this high port. Any incomming SIP message from the provider will go to the reported address i.e. *.*.*.*:13127, you obviously have no rule on this random port and hence the packet is dropped.

    You need to dedicate port 5060 to 192.168.1.45. Moreover you need to stop your firewall from doing that port translation when 192.168.1.45 sends a packet with source port 5060.
     
  5. godiz

    Joined:
    Sep 7, 2007
    Messages:
    4
    Likes Received:
    0
    thanks for your answer

    i'm still trying around. what i do not understand is the following:

    i made the firewall and nat settings to forward port 5060 to the server where the 3cx is installed. this pc for example alsways has this high port number. i tried to install the 3cx software on another pc (there are no port forwardings nor other firewall settings for this pc) and the stun setting port in the server status is x.x.x.x:5060. everything works fine on this pc. receive phone calls and so on. unfortunately this is a mobile pc, which i cannot use as the phone server. when i take a third pc and set up the 3cx on that, i get another stun setting in the server status with a high port addresse. for example x.x.x.x:16666. on another pc i get x.x.x.x:12490 and so on.

    i cannot figure out, how i can set this, so it works on the pc i want to. i forwarded your last answer to zyxel, so that they might help me to handle the port forwarding, because i don't have a clue how to change this. i almost drive crazy with this problem and don't know what to do next.

    does anybody know how to set this right? i would even like to pay for that support. this is not the problem.

    thanks very much

    simon
     
  6. godiz

    Joined:
    Sep 7, 2007
    Messages:
    4
    Likes Received:
    0
    i was trying all night long. the mobile pc never ever got the stun x.x.x.x:5060 again. so i was not able to call.

    i made some other settings and tryied the following.

    i change the port under "general settings" then "sip port" to anything else than 5060. restart the server (or pc). after that i am able to receive phone calls from outside, but cannot reach the extensions. under line status, the phones are "registered", but i cannot place calls from one extension to another, nor place a call to outside.

    i still try to figure out, how to make the stun entry to x.x.x.x:5060
    i did the following on my zyxel router (and firewall)

    opened ports 5060, 3478, 9000-9499 and routet them to x.x.x.x (where my 3cx is installed) also i routet all ports to the same ip address.

    i also tryied to deactivate the firewall for a test, but same thing. i cannot find a setting on my zyxel, where i can deactivate some port translation.

    does anybody know what i can do? or try? or does anybody can help me?
    thanks very much in advance

    simon
     
  7. kunle

    Joined:
    Sep 13, 2007
    Messages:
    6
    Likes Received:
    0
    Godiz I was having the same problem as you regarding stun not using port 5060 and incoming calls not working. I did what you suggested and changed it to port 5065 and was able to recieve calls but internal extensions no longer worked. I was just about to post here a cry for help when I read that you can replace the stun server address with your external ip address. I did this and and I was able to recieve incoming calls but certain features still did not work properly, I then changed the stun server back to stun2.3cx.com and everything is now works ok. Incoming and outbound calls are now ok.
    My router is a netgear fvs124g and my voip provider is voiptalk.
     

Share This Page