Incoming Direct SIP Calls Fail with Authentication Error

Discussion in '3CX Phone System - General' started by ITWorks, Apr 17, 2008.

Thread Status:
Not open for further replies.
  1. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    3CX Phone System Version5.1.4393.0
    X-Lite Softphone Version 3.0

    I have configure 3CX and DNS per 3CX Support instructions, however incoming direct SIP calls fail since upgrading 3CX version unless I configure an extension ID and password in 3CX and configure the same on the remote softphone. This was not necessary prior to upgrading 3CX and is rather impractical in implementation.

    [CM102001]: Authentication failed for SipReq: INVITE user.name@192.168.137.33 tid=fb69d548f9339a49 cseq=INVITE contact=user.name@222.111.22.11:17990 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings.

    222.111.22.11 is the outside IP address of my VOIP gateway. I have tried various Source Identification settings for the gateway with no success. Should an incoming Direct SIP call be required to authenticate?

    Thanks, Mark
     
  2. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Please try to set source identification rule to:
    Contact: Host/Port = Custom value 222.111.22.11:17990
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    Thank you for the suggestion Archie. Yes I had tried that configuration but same results. Everything works fine as long as the outside phone is configured as an extension. Anything else fails with the authentication error. To help eliminate gateway problems I made calls within the LAN but from different subnets by dialing a SIP URI to the IP address of the 3CX server. Are incoming direct SIP URI calls working fine for everyone else? If so, I think my settings for Direct SIP calls set under General Settings are not actually taking affect and I may need to reinstall.

    Mark
     
  4. alexmex

    Joined:
    May 7, 2008
    Messages:
    3
    Likes Received:
    0
    Hello Mark, I´m actually having the same problem it was working on a previous version and just upgraded to 5.1. I tried different softphones and different network configurations but no luck.

    Regards
    Alex
     
  5. nateb

    Joined:
    Oct 19, 2007
    Messages:
    68
    Likes Received:
    0
    that is the same error message i was getting.
     
  6. vale

    Joined:
    Nov 2, 2007
    Messages:
    9
    Likes Received:
    0
    I am also having the same problem. I was looking at the DNS configuration on the support section and I think thats for outgoing direct sip calls only (correct me if I am wrong) so I left that alone. I just created a sub domain to my sbs server which re routes sip calls to my 3CX server. The calls from my softphone (SJPhone) seem to be reaching the server but I also get the authentication problem.

     
  7. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    As you can see in bold selection - username is empty. In this case PBX will never authorize such INVITE. Username should be the same as your extension number.
    And to be treated as incoming direct SIP call you should address it to SIP ID, not extension number.
    So, if you have ext.208 - define a SIP ID for it (let say - 'vale'). After that if your invite has To: <sip:vale@sip.mydomain.co.uk> and sip.mydomain.co.uk is defined as your SIP Domain -- it will be accepted as Direct SIP call (without athentication at all).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. vale

    Joined:
    Nov 2, 2007
    Messages:
    9
    Likes Received:
    0
    Hmmm in my General Settings -> Direct SIP Calls I have the domain set to sip.mydomain.co.uk

    On my sip phone I am typing James@sip.mydomain.co.uk
    The sip phone then dials and I am getting that authentication problem. How do I get my SIP ID into that username field like you mentioned? Is there something I have not done?

    EDIT: I have got it working now it would seem I was typing James with a lower case j hence why it was not authenticating. Thanks for your help.
     
  9. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    In extension settings under 'Other options' you will find 'SIP ID' field. It should be filled with 'James' if that extension should receive direct SIP calls addressed as James@sip.mydomain.co.uk.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.