incoming number without first 0

Discussion in '3CX Phone System - General' started by Mann-IT, Aug 16, 2009.

Thread Status:
Not open for further replies.
  1. Mann-IT

    Joined:
    Aug 14, 2009
    Messages:
    3
    Likes Received:
    0
    Hallo,

    ich have follow problem. whem somewone is calling me the first 0 is not show.
    eg. the number is 09523 but on my phones there are only 9523 but i need the 0 to call back

    3cx 7.1.7139
    Patton 4638 5.3 2009-07-14

    The 3cx support told me there a other template to use, i don't understand because not only i can have this problem.

    regards Mario
     
  2. Discovery Technology

    Joined:
    Apr 19, 2008
    Messages:
    278
    Likes Received:
    0
    This depends upon the telco you are using - some strip the leading zero, some do not.

    To resolve this, you simply need to manually add the following line to the config file before you upload it to the Patton gateway:

    national-prefix 0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Discovery Technology

    Joined:
    Apr 19, 2008
    Messages:
    278
    Likes Received:
    0
    I should have also mentioned that you should place it after the context cs-switch line...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Mann-IT

    Joined:
    Aug 14, 2009
    Messages:
    3
    Likes Received:
    0
    you are my hero :) it works

    now i have follow problem to i can't get any fax. ind the mediaserver trace log ist follow

    o=3cxPS 522895491072 56287559681 IN IP4 127.0.0.1
    s=3cxPS Audio call
    c=IN IP4 127.0.0.1
    t=0 0
    m=audio 7066 RTP/AVP 8 0 101
    c=IN IP4 127.0.0.1
    a=rtpmap:8 PCMA/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=sendrecv

    14:54:18.296|.\MediaServer.cpp(1127)|Trace5||??:EndPoint 00000022@ removed from call 17
    14:54:48.625|.\MediaServer.cpp(1127)|Trace5||??:EndPoint 00000021@ removed from call 17
    14:54:48.671|.\MediaServer.cpp(886)|Trace5||??:references to EndPoint 00000021@ were removed
    14:54:48.671|.\MSEndPoint.cpp(686)|Trace5||??:EndPoint 00000021@ destroyed
    14:54:48.671|.\MSEndPoint.cpp(687)|Trace5||??:EndPoint 00000021@ destroyed statistics:
    Begin send:0
    LastSent:0
    TotalSent:0
    MaxSendInterval:0
    MinSendInterval:0
    AvgSendInterval:0
    SendDeviation:0
    Begin recv:0
    Last recv:0
    TotalRecv:0
    MaxRecvInterval:0
    MinRecvInterval:0
    AvgRecvInterval:0
    ReceiveDeviation:0

    14:54:48.671|.\RTPReceiver.cpp(127)|Trace5||??:Endpoint for socket 776 is not found!
    14:54:50.500|.\MediaServer.cpp(886)|Trace5||??:references to EndPoint 00000022@ were removed
    14:54:50.500|.\RTPReceiver.cpp(127)|Trace5||??:Endpoint for socket 508 is not found!
    14:54:50.500|.\MSEndPoint.cpp(686)|Trace5||??:EndPoint 00000022@ destroyed
    14:54:50.500|.\MSEndPoint.cpp(687)|Trace5||??:EndPoint 00000022@ destroyed statistics:
    Begin send:0
    LastSent:0
    TotalSent:0
    MaxSendInterval:0
    MinSendInterval:0
    AvgSendInterval:0
    SendDeviation:0
    Begin recv:0
    Last recv:0
    TotalRecv:0
    MaxRecvInterval:0
    MinRecvInterval:0
    AvgRecvInterval:0
    ReceiveDeviation:0

    14:54:50.515|.\MediaServer.cpp(1205)|Trace5||??:references to call 17 were removed
    14:54:50.515|.\MSCallConf.cpp(33)|Trace5||??:Call: 17 destroyed
     
  5. Discovery Technology

    Joined:
    Apr 19, 2008
    Messages:
    278
    Likes Received:
    0
    codec issue, perhaps?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.