incoming phone don't work always

Discussion in '3CX Phone System - General' started by Francisco_javier, May 10, 2011.

Thread Status:
Not open for further replies.
  1. Francisco_javier

    Joined:
    May 10, 2011
    Messages:
    2
    Likes Received:
    0
    I have a sonicwall TZ210 as firewall and work with provider 3starsnet Belgium and 3CX run on a XP workstation.

    To call internal and external someone , no problem.
    To receive a call , if the destination port is 5060 than I receive the call, else the call is lost.
    Can y tell to 3CX to force to use the destination port 5060?.

    Thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    I'm a bit confused. What device do you wish to change the port on?

    When a SIP device (including 3CX) registers with a server, it tells the server what port it want to "receive" on. That port number, in almost all cases, can be set to a port number that will work (won't cause conflicts).
     
  3. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    Just about all SIP providers use 5060 for the SIP port. If you want to use a different port then your in for a rough time. all phones and servers and providors use 5060 so to change it will be a tremendous task.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Francisco_javier

    Joined:
    May 10, 2011
    Messages:
    2
    Likes Received:
    0
    My question was,

    If a monitor a incoming call on my sonicwall, the source port is always 5060 but the destination port is sometimes other than 5060, for example 11474.

    If the destination port is different then 5060 the incoming call is not working.

    Who change or with unit give the destination port, the firewall (sonicwall TZ210 in my case) or the 3CX soft,

    If it is the 3CX software is it possible to fix the destination port to have always 5060.


    Thanks
     
  5. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    The destination port should be 5060. The source port could vary. If your seeing different destination ports from inbound calls from your VOIP provider you should contact them with your logs and see what they say. Have you tried sniffing on the outside of the sonicwall to verify what your seeing in your sonicwall logs? Outbound traffic via NAT will always grab a random high number port, but the inbound traffic from your voip provider to your 3cx should always be 5060.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    on the sonicwall under the voip tab make sure to enable constant nat and disable sip transformations.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.