Incoming PSTN call gets "dial-tone" while 3CX forwards call

Discussion in '3CX Phone System - General' started by Andy Schmidt, Apr 10, 2008.

Thread Status:
Not open for further replies.
  1. Andy Schmidt

    Andy Schmidt New Member

    Joined:
    Apr 3, 2008
    Messages:
    118
    Likes Received:
    0
    Hi,

    Just installed 3CX to evaluate before purchasing. I know my way around TCP/IP, routers, and various Internet protocols, etc., but am totally new to the world of SIP and VOIP.

    During test has a single phone line (201-934-9265) going into first port of AudioCodes MP-118 (with 8 FXOs).
    No automated attendant yet in 3CX. So for now, I configured 3CX to send calls from the PSTN gateway directly to my extension (20).

    When I dial that number from the outside (using regular POTS phone), the line rings, then the PSTN gateway picks up (I assume). Then, I immediately get a loud dial-tone - as if I had lost the connection. However, if I stay on the phone, then a while later my extension rings on my Grandstream 2020 and I can actually pick up the call.

    So - my question is:
    How do I tell either the AudioCode OR the 3CX to be "quiet" while the call is being transferred to an extension?

    Here the log entries:
    18:26:23.137 Call::Terminate [CM503008]: Call(11): Call is terminated
    18:26:23.121 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
    18:26:23.121 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
    18:26:23.121 Call::Terminate [CM503008]: Call(11): Call is terminated
    18:26:23.121 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
    18:26:12.170 CallCtrl::eek:nLegConnected [CM503007]: Call(11): Device joined: sip:20@63.107.174.156:5060;transport=udp
    18:26:12.170 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
    18:26:12.170 CallCtrl::eek:nLegConnected [CM503007]: Call(11): Device joined: sip:10800@63.107.174.136:5060
    18:26:04.687 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(11): Calling: Ext:20@[Dev:sip:20@63.107.174.156:5060;transport=udp]
    18:26:04.671 Line::printEndpointInfo [CM505002]: Gateway:[PSTN] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Audiocodes-Sip-Gateway-MP-118 FXO/v.5.00A.024] Transport: [sip:63.107.174.130:5060]
    18:26:04.671 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
    18:26:04.671 CallCtrl::eek:nIncomingCall [CM503001]: Call(11): Incoming call from 2019349260@(Ln.10800@PSTN) to [sip:20@sip.usa.hm-software.com:5060]
    18:26:04.671 LineCfg::getInboundTarget [CM503011]: Inbound out-of-office hours' rule for LN:10800 forwards to DN:20
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. magpye

    Joined:
    Apr 13, 2008
    Messages:
    1
    Likes Received:
    0
    Have you tried using a soft client ? Might be useful to see if it's because of the routing or the hardware.
    If you use a softclient, and it still gives dial tone, check the routing info. Otherwise it suggests a delay in the Grandstream phone picking up the call.
     
  3. Andy Schmidt

    Andy Schmidt New Member

    Joined:
    Apr 3, 2008
    Messages:
    118
    Likes Received:
    0
    Thanks for takign the time and responding. I had I worked around that part (but may have gone about it the wrong way) - and now I'm having other problems. (I'm shocked that I made a point of purchaing "supported" hardware and copied the setup information for the AudioCodes unit - yet, it's not working as documented! Not a good installation experience - I had meant to go buy my license and uprade insurace etc last week, but had to hold off since there is obviously no guarantee that this will actually work as documented.)

    Here's what I did thus far in the AudioCodes FXO unit:
    - Changed HotLine Dial Tone Duration from 16 to 0 sec in "DTMF and Dialing"
    - Changed Time to Wait before Dialing down to 10 msec in "FXO Settings"

    With these two changes, the incoming calls are picked up right-away, without a very long "secondary dial tone".

    However, THAT introduced the problem that my outbound dialing was no longer working, because it apparently started dialing the phone numbers BEFORE the local bell was ready. I fixed THAT problem by setting:
    - Wait for DialTone = Yes (in FXO Settings)

    This leaves me with two remaining problems:

    Problem 1:
    - After an incoming POTS call hits the automated attendant, the CALLER hangs up the call durign the announcement. All seems well.
    - However apparently the gateway NEVER ends the call or doens't tell the PBX about it. The automated attendant apparently waits for the timeout and then does the default action (go to operator's extension).
    - The operator then picks up the call and is connected to Verizon saying "if you like to make a call..."

    Problem 2:
    - I can dial outbound calls just fine, however, I miss the first second or two of the person answering the phone!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.