Incoming rules not working

Discussion in '3CX Phone System - General' started by raceface2nd, Jul 6, 2017.

Thread Status:
Not open for further replies.
  1. raceface2nd

    Joined:
    Jul 6, 2017
    Messages:
    6
    Likes Received:
    0
    Hi,

    I have a 1-igit (so from 0-9) trunk to my main number at easybell. The problem I have is that with 3CX all incoming calls independend of the suffix are routed to the extension 000. E.g.when I set incoming rule like <number>9 send fax to 888 they are not routed to the internal fax server but routed to extension 000. This is happening to all incoming calls, independend wich DID I am calling.

    What might be wrong configured? Connecting a fritz.box to the easybell trunk and chosing DID ...9 as fax it works like expected, so I believe it's not easybell.

    The image shows the incoming roules.

    [​IMG]

    Thx!

    Andy
     
  2. raceface2nd

    Joined:
    Jul 6, 2017
    Messages:
    6
    Likes Received:
    0
    There seems to be a general problem with that trunk. Even if I create a new DID and assign it to a different extension all direct calls to this DID are routed to the 000 extension. Doesn't look like usual behavior to me.
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Hello @raceface2nd

    When setting up inbound rules you should keep in mind that 3CX will try to match the incoming number to the number of the DID. If the number matches then the call will routed according to the Inbound rule you created. If the incoming number does not match the number specified as a DID then the call will be routed to the default destination of the trunk.
    For example if the number arrives at the PBX as 004412345678 and the DID is specified as 4412345678 then the call will not be routed according to the Inbound rule but will go to the destination of the main trunk number.
    To avoid this you can either set up your DID's according to the format that arrives at the PBX or use a * to let the PBX know to match only the numbers after the *. So you can set the number of the previous example as *12345678 so it will match the number if the number arrives as 004412345678 or 4412345678 or 12345678. The * can only be used at the beginning of the number.
    You can also find info about inbound rules here: https://www.3cx.com/docs/manual/inbound-rules/
     
  4. raceface2nd

    Joined:
    Jul 6, 2017
    Messages:
    6
    Likes Received:
    0
    Dear Yannis,

    Thank you very much! Using an asterisk instead of country code and area code did the trick. Is there a way to find out in which format the trunk provider (in my case easybell) is submitting the phone number which was dialled by the caller?

    Thx! Andy
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    You can check the activity log of the PBX (i believe you need to set it to verbose) filter by call and see the To: field on how the number is arriving to the PBX.
    Glad to hear it is working now
     
Thread Status:
Not open for further replies.