Incoming SIP call not working

Discussion in '3CX Phone System - General' started by vin944, Aug 28, 2008.

Thread Status:
Not open for further replies.
  1. vin944

    Joined:
    Aug 20, 2008
    Messages:
    7
    Likes Received:
    0
    I have an IPKall number forwarded to my new 3cx SIP server. I use 100@xxxxxx.myvnc.com. I would assume this would ring ext 100. But I just get a busy signal. I have all the respective ports forwarded to the 3CX machine (I think) and my domain name is resolvable. I have a voip line that I forwarded to ext 100. If I point the IPKall number to user@voipstunt.com, the call will complete and go to ext 100. But when I try to go directly, it doesn't work. Any ideas? Thanks.
     
  2. frydendal

    Joined:
    Aug 30, 2008
    Messages:
    16
    Likes Received:
    0
    Do you have config DID?...
     
  3. vin944

    Joined:
    Aug 20, 2008
    Messages:
    7
    Likes Received:
    0
    Yes I have an IPKall. I set IPKall to 3cx user # 100 and then the domain to xxxxx.myvnc.com. But just busy signal. I have used the IPKall before to other sip urls and no problem. Thanks.
     
  4. worksighted

    worksighted New Member

    Joined:
    Aug 19, 2008
    Messages:
    204
    Likes Received:
    0
    Does ext 100 have the sip id (at the bottom of the options in the extension setup...under "other options") set to 100......it could be unset or set to something different at the moment.

    What do your server logs show....is the call reaching the PBX?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. vin944

    Joined:
    Aug 20, 2008
    Messages:
    7
    Likes Received:
    0
    The SIP ID was not set to 100. Thank You. It is working now. :) But also one more question. Can all extensions be done in a similar fashion. Let's say 101 for example. Just set 101 in "other options"? Thanks again.
     
  6. worksighted

    worksighted New Member

    Joined:
    Aug 19, 2008
    Messages:
    204
    Likes Received:
    0
    Yes, you can. The SIP ID does not have to be the same as the extension number if you dont want. For example bob@xx.yy.zz could be extension 100.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. vin944

    Joined:
    Aug 20, 2008
    Messages:
    7
    Likes Received:
    0
    I played around with that a little but it seems that if the SIP ID is anything but the ext number, I get a busy. I tried to make the SIP ID a different extension but that didn't work. I tried to make it a sip url and that didn't work either. But at least it is working with the ext number.
     
  8. tranceaddict

    Joined:
    Jan 5, 2009
    Messages:
    17
    Likes Received:
    0
    Hey Mike,
    Iam having a similar issue as defined by the other user in this post.. When I call the IPKALL number which is forwarded to an extension on my 3CX box, I just get a busy tone..
    The real strange thing is that it was working fine for a while and now it has just stopped. I have all the requisite ports forwarded and I checked the SIP ID on the "Other" option tab for the extension.. All seems to be in order. Here is what I get from my log for incoming calls. The IPKALL server is definitely reaching my 3CX box.. Any ideas? No RTP packets ever get started because the connection never happens.

    18:12:44.328 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:100@mydomain.com SIP/2.0
    Via: SIP/2.0/UDP 66.54.140.46:5060;branch=z9hG4bK6233c1e5;rport=5060
    Max-Forwards: 70
    Contact: <sip:1234567891@66.54.140.46>
    To: <sip:100@mydomain.com>
    From: "WORCESTER MA"<sip:1234567891@66.54.140.46>;tag=as21142755
    Call-ID: 0ed5746f447f203417cada67749be42e@66.54.140.46
    CSeq: 102 INVITE

    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

    Date: Sat, 28 Mar 2009 22:12:44 GMT

    Supported: replaces
    User-Agent: Asterisk PBX
    Content-Length: 0

    18:12:44.328 [CM302001]: Authorization system can not identify source of: SipReq: INVITE 100@mydomain.com tid=6233c1e5 cseq=INVITE contact=1234567891@66.54.140.46 / 102 from(wire)

    ----------------------------------------
    I have masked the phone number to be 1234567891 and the domain to be mydomain.com

    Thanks!
    TA
     
  9. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Set SIP ID of your extension 100 to "100"
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    How about the conference room, ring group, DR and call queue? From extensions using direct SIP works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Ricky,

    Only extensions support "direct sip" calls. You can use the technique like "just make the fake extension which will forward calls to desired destination...". I expect that you will immediatelly get a lot of options and features to control SIP ID behavior...

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,117
    Likes Received:
    146
    Hi tranceaddict (listening to state of trance at the moment :) ARMIN!!! )

    In many cases, verbose logs help you identify the problem.
    The logs are showing you that something is not normal here

    18:12:44.328 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:100@mydomain.com SIP/2.0
    Via: SIP/2.0/UDP 66.54.140.46:5060;branch=z9hG4bK6233c1e5;rport=5060
    Max-Forwards: 70
    Contact: <sip:1234567891@66.54.140.46>
    To: <sip:100@mydomain.com>
    From: "WORCESTER MA"<sip:1234567891@66.54.140.46>;tag=as21142755
    Call-ID: 0ed5746f447f203417cada67749be42e@66.54.140.46
    CSeq: 102 INVITE

    Do you see the first line: Unidentified incoming call. Review INVITE and adjust source identification:

    This means that you have to adjust source identification

    Try the following:

    Click on the provider
    Souce identification tab
    Match Any Field
    Contact host part -> CUSTOM Field -> and add this 66.54.140.46

    This is the IP of the provider - the contact point for your provider- ie: voiper.ipkall.com. This can never change as long as you stick with this provider. Calls will always come from this IP if 1234567891 is dialled correct? Then the invite will be authenticated and will be allowed. This is Adjusting Source and reviewing the invite. in other words helping the pbx identify an unidentified Invite. The invite will always have this contact in the host part of the contact if it comes from this provider. Therefore with this you are safe. This is very common when unsupported providers. We call them Unsupported not because they will not work. Far from it. If the provider abides to sip standards, they will work. The problem is that in an unsupported provider some manual changes may be required. Case in point ipkall.

    You have to find something that is common in all the invites. Something that can never change - like the providers ip address for example - that is always constant. Even the dialled number (if you have no DID's or MSN of course.) The telephone number given to you will never change correct? I would stick to the providers IP.

    Hope this helps
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. tranceaddict

    Joined:
    Jan 5, 2009
    Messages:
    17
    Likes Received:
    0
    Hi Nick,
    Thanks for actually taking the time to read through my log and providing useful feedback. Since I already had the SIP ID set to the extension #, I knew that wasn't the issue.

    Your "Source Identification" setup was what I was missing. That did the trick.. While this makes sense for any numbers that one wants to setup as DID for extensions, does it also mean that each and every SIP server where you expect to receive a call from has to be setup as a provider with source IDs.

    Sorry if my question doesn't make sense as I am still trying to learn and understand SIP systems

    Thanks,
    TA

    and yes Tiesto and Armin rule!!

    "Forever Addicted but never corrupted"
     
  14. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,117
    Likes Received:
    146
    Hi
    No problem

    The providers that we support (ie the ones that you see in the system) dont need source identification. Simply because we have tested those providers in our testing lab and we cater to identify them. The final question depends on which provider you are using.

    Unsupported providers will work but a certain phase of testing and experimentation is needed to get them up and running sometimes. It is very common that unsupported providers need a modification in the source. Or some change in the template. Basically this is done for compatibility purposes because these providers would have never been tested by 3CX before.

    Source identification should be added only if you see that message in the logs. If you don't then you don't have to add it. Another case where source id is involved is when the message of unidentified source is not seen in the logs but DID's still do not work and instead of forwarding to destination specified in the inbound rule, they get forwarded to the destination of the main number. In this case (which happens in a voip provider scenario) in the tab called source Id. there is a section which is grayed out. have a look at the i fields - if you have any questions let me know.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.