Incomming calls end after short times

Discussion in '3CX Phone System - General' started by sonlm, Oct 1, 2007.

  1. sonlm

    Joined:
    Mar 28, 2007
    Messages:
    13
    Likes Received:
    0
    Hi,

    I have 3CX used with Linksys SPA-3102. Everything went ok but that:

    When it has an incomming call, the conversation was sometimes stopped halfway (after about 15-20s or maybe longer) and sometimes finished well. It is not stable.

    What's the reason and tell me somethings to do.

    Thanks and regards,
    Sonlm
     
  2. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    Heya, make sure that on the PSTN line you have the "PSTN detect long silence" you have it set to No, so that the line wont disconect if it detects any silence(sometime doesnt need to detect silence to disconnect).

    Cheers
     
  3. Ryandc

    Joined:
    Aug 13, 2007
    Messages:
    70
    Likes Received:
    0
    You need to post your logs if you're dropping calls so we can determine if it's your phone, the remote end, or a gateway device that's sending the disconnect signal.

    If you're getting a "hangup from wrong leg has arrived" message ANYWHERE in your logs, then your NAT traversal isn't working, possibly due to STUN or other probs. Bind your Gateway to your PBX.

    But, in this case, logs would help out. A lot.
     
  4. sonlm

    Joined:
    Mar 28, 2007
    Messages:
    13
    Likes Received:
    0
    Following is my server log with 1 dropping call:


    It looks like a bit confusion :)
    I think it's my gateway which sending the disconnect signal.

    I set "Detect PSTN long silence" to YES and "PSTN long silence duration" is 15. But even when it's set to NO, calls still interrupted.
     
  5. Ryandc

    Joined:
    Aug 13, 2007
    Messages:
    70
    Likes Received:
    0
    You can ignore all that STUN server stuff. Basically, the problem is here:

    14:46:30.187 StratLink::eek:nHangUp [CM104001] Call(7): Ln:10000@SPA-3102 hung up call; cause: BYE; from IP:10.0.0.60

    Whatever device you're using at 10.0.0.60 is sending a "BYE" without it being requested by either party. You're right in looking at the PSTN long silence detection. Make sure you're using current firmware for whatever device it is.


    14:45:57.187 CallLegImpl::eek:nConnected [CM103001] Call(7): Created audio channel for Ext.102 (10.0.0.61:10010) with third party (10.0.0.60:16422)


    14:45:57.171 StratInOut::eek:nConnected [CM104005] Call(7): Setup completed for call from Ln:10000@SPA-3102 to Ext.102


    14:45:57.171 CallLegImpl::eek:nConnected [CM103001] Call(7): Created audio channel for Ln:10000@SPA-3102 (10.0.0.60:16422) with third party (10.0.0.61:10010)



    14:45:48.828 CallConf::eek:nProvisional [CM103003] Call(7): Ext.102 is ringing


    14:45:48.187 CallConf::eek:nIncoming [CM103002] Call(7): Incoming call from 047152098 (Ln:10000@SPA-3102) to sip:10000@10.0.0.54:5060
     

Share This Page