Incorrect CLI on some mobile phones, but not others

Discussion in '3CX Phone System - General' started by Tom Cowley, Nov 9, 2017.

Thread Status:
Not open for further replies.
  1. Tom Cowley

    Joined:
    Aug 21, 2017
    Messages:
    8
    Likes Received:
    1
    When I ring a colleagues mobile phone from any of the phones in my business, it presents the CLI as the main SIP trunk number. However when I ring MY mobile phone from the same phones, it presents the correct caller ID (specified in the extension configuration on the 3CX). I have multiple businesses using the same system, so cannot have this happen. Why would there be such an inconsistency? My telco says it's not them, but I'm not sure.

    Would appreciate advice - thanks.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,584
    Likes Received:
    252
    If the provider allows it, and it sounds as if yours does, then (depending on the outgoing settings in the trunk , in 3CX), the number to be displayed in outside calls, that you have set in an extension, will usually override the "Main" number set against the trunk. This behaviour is usually consistent over all called numbers. If Caller ID from the same 3CX extension, changes when calling some numbers, then you need to confirm what is actually being sent. You could check the 3CX Activity Log and look for differences between a call to your mobile and a call to another number, where CID is different in each case. Wireshark would also confirm what is being sent. If it appears to be consistent, in both calls, then have a chat with your provider and present them with the call information you have collected.

    Can the CID dependency, be duplicated when calling other mobiles on the same network as yours?
     
    YiannisH_3CX likes this.
Thread Status:
Not open for further replies.