Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Incorrect source of RTP stream**V10 FINAL SUPPORTS THIS

Discussion in '3CX Phone System - General' started by LPGregory, May 5, 2011.

Thread Status:
Not open for further replies.
  1. LPGregory

    Joined:
    Oct 18, 2010
    Messages:
    5
    Likes Received:
    0
    I recently upgraded to V10 from V9 and now cannot get audio to go out to whomever I call. I have 3cx server connected to the LAN port on a Grandstream HT502 that is acting as a fsx for two analog phones. the WAN side of the Grandstream connects to a Linksys router which in turn is connected to a cable modem. Before the upgrade this setup worked and now after the upgrade I cannot get outgoing audio I cannot be heard on the other end of the call. Incoming audio works fine ( I hear their audio). I am using Skype with which to call out on and receive calls. The following is from the Server Activity log.
    Everything seems to be registered correctly. What am I missing in the setup?



    15:36:49.131 [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 96.9.132.83:3478 over Transport 192.168.2.100:5060
    15:33:19.634 [MS105000] C:7.1: No RTP packets were received:remoteAddr=192.168.1.101:5004,extAddr=0.0.0.0:0,localAddr=192.168.2.100:7024
    15:33:19.084 [CM503008]: Call(7): Call is terminated
    15:33:19.066 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:19.045 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:19.028 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:19.006 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:18.985 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:18.968 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:18.946 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
    15:33:18.925 C:7.1(LOCAL):Incorrect source of RTP stream. expected:192.168.1.101:5004 but received from 192.168.2.1:5004
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,101
    Likes Received:
    329
    Re: Incorrect source of RTP stream problem

    Does that Grandstream have a built in router? If so DHCP should be disabled and the LAN port should be set to "Bridged". Your logs are showing two subnets, when there is really no need. All private IP's should be in the range used by your router unless you have a specific reason to do otherwise.
     
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,153
    Likes Received:
    172
    Re: Incorrect source of RTP stream problem

    LPGregory

    Contact me by email - nb@3cx.com

    I need to ask you some questions about your network.

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    8
    Hi Nicky,

    we have the same problem in your network, we work with VPN
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,153
    Likes Received:
    172
    I did not understand your question.

    This this particular thread the case of incorrect source of RTP stream was a result of incorrectly configured devices resulting a network scenario offering triple nat. If you have the same problem, then you must fix it. So no wonder there is an incorrect source of RTP stream.

    Now Version 10 is going to expose errors and incorrect behavior of devices that you had before but v9 used to correct it. (or ignore it)

    This is something that you guys can fix on your own because you have control of your devices.

    If you do not want to fix it, we offer a parameter in the 3CX Phone system.ini called msNoRTPFilter=0 - uncomment it and you will have the old behavior of v9.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    8
    the problem that we have:

    we have 2 network, links with VPN (2 endian firewall) PBX is on the first network. on the other; 3cx phone connecte troughout VPN. before with v9 sometime works, sometime not. today with v10, in fact i see RTC error (fine ;) ).

    the only mean that i found it's use tunnel and it's work. but if you know mean to correct this error, it will be interesting.

    tks advance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,153
    Likes Received:
    172
    This is much better with more details.

    When you see that something is working with the tunnel and not working without tunnel, then there is a port mapping problem. Because the tunnel all it does is merge all the traffic on port 5060 + all the audio traffic on audio ports, into 1 single port 5090.

    So when you see that if you move everything on 1 port (tunnel), it works and if you go direct it doesn't, then there is a network problem of some sort.

    I can suggest something if you want. You have to open wireshark on the machine of the 3CXPhone. open wireshark on the machine of the 3CX Phone system, make a call without tunnel and first find the problem from where it is coming. See the source and destination ports, and how they arrive to the destination.

    If you get rtp error, that means that the sip is ok. Because the phone registers. So all you have to do is focus on the rtp streams and port translations. Let me know how this goes. Without an investigation of what is happening from your side, we cannot go further to resolve this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    8
    See error message

    14:57:08.283 [MS105001]C:751.1(LOCAL):Incorrect source of RTP stream. expected:192.168.2.73:40012 but received from 192.168.2.73:49086

    my server is on 192.168.1.x

    i will do wireshark capture.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,153
    Likes Received:
    172
    From what I can see is that

    3CX Phone in its sdp after passing through the NATTING, told 3CX Phone system to communicate with it on 192.168.2.73:40012 - this is why it says expected:192.168.2.73:40012

    Instead when audio tried to be delivered, 3CX Phone system received audio from 192.168.2.73:49086 which does not match.

    As you can see the ports are different. This means that RTP packets did not arrive from port 40012 but from 49086.
    (try and do that parameter I told you msRTPfilter=0 see if this works. - restart all services after)

    So something changed the port. first question to ask is this. What is between 3CX Phone system and 3CX Phone?

    yes I know there is a VPN, but a VPN is not created on its own. Some VPN device must be sitting in between. Now this device is not keeping the port mapping it sent before and is generating a new random port. Probably this is the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.