Incorrect sourceRTP Stream**FIXED-SANGOMA Improvement

Discussion in '3CX Phone System - General' started by paul.hadley, Apr 16, 2011.

Thread Status:
Not open for further replies.
  1. paul.hadley

    paul.hadley New Member

    Joined:
    Aug 24, 2010
    Messages:
    122
    Likes Received:
    0
    I have been using V9.0 for a while as my home PBX. I also have another PBX on the same server from my company. I linked my company PBX through an extension on my home PBX and it worked fine.

    Now after installing V10 the audio stream is failing (One Way Audio) with the following message

    Incorrect source of RTP stream. expected : 192.168.61.240:8000 but received from : 127.0.0.1:8000

    Are there any settings so that 3CX see's that the two addresses are the same computeras it did in v9.0
     
  2. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect source of RTP Stream

    Every call has one way audio? WHat nature is this call?
    Do you have ring my mobile simultaneously?
    Which pbx did you upgrade? The company or the home?
    What extension did you use to connect to your company pbx? Type of phone?
    How did you configure it? Probably you have a port mapping problem because the correct way to implement this is the following:

    If you have a cvompany pbx and a home pbx to normally connect both pbx's using a bridge or a tunnel.
    To connect an extension to the company pbx, you would not normally have a PBX at home.

    However everything is possible and if configured correctly both scenarios can work with Version 10.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. paul.hadley

    paul.hadley New Member

    Joined:
    Aug 24, 2010
    Messages:
    122
    Likes Received:
    0
    Re: Incorrect source of RTP Stream

    I have a company PBX running on port 5065 and RTP 8000 - 8499 IP 192.168.61.240

    On the same server I have 3CX on Port 5060 RTP Local 7000 - 7499 and External 9000 - 9499 IP 192.168.61.240

    Connected to the company server is a Polycom Ip500

    Connected to 3Cx is three Grandstream GXP2000

    In order that I only have one phone on my desk I created an extra extension on 3CX and then logged the company PBX into that as a serice provider (VoiP Provider). Thus if a call comes in on my personal line the 3 GXP's ring directly and the Company PBX rings and then onto the Polycom. From the polycom I use the relevant access code to use 3CX as a provider which then uses my own internet account.

    This worked fine with V9.0. But on V10 when you take the call on the polycom you can still hear the caller but the caller can not hear you. The RTP stream from the company PBX to 3CX works fine but the stream back from 3cx now fails, it expects a stream from the IP 192.168.61.240 but actually gets a stream from 127.0.0.1. and then reports it did not receive a reply from 192.168.61.240. Although this is the same source it no longer reconises this and fails. I did a quick back install of V9.0 to see if anything else might be a problem but no the setup works fine in v9.0

    Also tried moving 3CX onto a different computer and this works fine, however I don't want the expense of running a second computer just for this. I just need to work out how to get 3CX to reconise the stream is coming from the right source as it did in V9.0. I guess if 3cx and sip softphone were installed on the same computer a similar problem would occur.
     
  4. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect source of RTP Stream

    I do not understand - you have 2 pbx's running on the same machine?

    One is 3rd party and the other is 3CX? What is the 3rd party company pbx?

    Why would you want to have this scenario?

    Of course it will work on another machine - Ports needed are probably being stolen by 1 of the pbx's.

    Tips - Change the ports of the other pbx and use 60000 range for example - A high port number.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. paul.hadley

    paul.hadley New Member

    Joined:
    Aug 24, 2010
    Messages:
    122
    Likes Received:
    0
    Re: Incorrect source of RTP Stream

    Yes there are two PBX's running, 3cx for personal use and Axon PBX for the company.

    Why, because the Axon setup has company voice mail so I have to use it. The 3cx is for my own personal use. I don't want my peronsal accounts on the company PBX or the grandstreams to have any access to the company account or voice mail.

    Ports are fine, the identical setup works with 3cx v9.0. Took a backup from this before installing V10 and used that to configure V10 so the setup is identical, ports etc. The problem only happens in v10 so it must be something that has changed on V10, the way it reconises the source IP. 3cx does not reconise that 192.168.61.240 and 127.0.0.1 are the same source any more as it did in v9.0
     
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect source of RTP Stream

    3CX is expecting traffic from ip:8000. The 8000 range is responsibility of this pbx you are using. You need to check why this pbx first promises to negotiate audio on 192.168.X.X:8000 and actually sends it from 127.0.0.1:8000.

    In Version 10 3CX Media server filters traffic and checks to receive traffic from what is promised in the sdp. If this is not equal to what promised it is considered as spam. This is why v9 used to work because v9 used to accept spam. Spam is extra traffic which is not good for us.

    Also this is an unsupported scenario. 2 PBX's from different manufacturers on the same host. You should decide which road you want to take. Problems like this will be waiting to happen. This is an unprofessional scenario.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    Could this be why the Sangoma a102d T1 card worked in v9 but now I cannot get audio to the handset?
     
  8. wzaatar

    Joined:
    Aug 1, 2007
    Messages:
    90
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    Hello everyone,

    I am having the same error message but for a different reason.

    I'm running a SIP client over 3G and it looks like that the operator is performing asymmetric NAT, resulting in a correct IP but an incorrect port.

    Is there a possibility to turn the "Spamming Check" off for these cases via a custom parameter?

    Thanks,

    Wadih
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    wzaatar - are you using v10? Go to the custom parameter table and find this
    ALLOWSOURCEASOUTBOUND

    What is your current setting?

    Brentrichburg - before we know for sure we need to check the media server logs - can you check in the server activity logs and see whether you see this message?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    This is the error I received.

    13:55:56.700 C:30.2(LOCAL):Incorrect source of RTP stream. expected:10.9.25.82:14000 but received from 127.0.0.1:14000

    ALLOWSOURCEASOUTBOUND is set to 0
     
  11. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    I changed ALLOWSOURCEASOUTBOUND to 1 and still get an error.

    14:51:18.169 C:3.2(LOCAL):Incorrect source of RTCP. expected:10.9.25.82:14007 but received from 127.0.0.1:14007
     
  12. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    Here is what I got from Sangoma Support


    ____________________________
    Hi Brent
    I apologize for the late reply. I have had our netborder team look at this
    issue and it does look like your RTP is being streamed to an incorrect
    location. It does have to do with an issue with 3CX version 10 and we have
    contacted the 3CX team in order for them to fix the issue.

    In the meantime, i suggest moving down to version 9 as that version seems to
    be working without this issue.

    Your Support Team
    ___________________________
     
  13. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    How did you configure the sangoma? You should put 127.0.0.1 as the ip address of the sangoma both in 3CX and also in the sangoma card.

    Yes they are right. As I stated before some procedures changed from V9 to V10. in V9 we used to ignore these RTP changes. In version 10 we don't. We are reasoning like this. If the device promised to send Media from 127.0.0.1:8000, then we expect to receive it on that IP and port not from 192.168.X.x : PORT.

    The network stack in XP and 2003 is different than that of Windows 7 and server 2008 so we had to adhere to their changes as we move forward.

    Where is the pbx and the sangoma card installed? What is the operating system?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    The Sangoma and 3CX are installed in the same machine. It is running Windows 2003 R2. I will change all references to the IP address of the card in both 3CX and the NBE Gateway configuration to 127.0.0.1 and see if that will work.
     
  15. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    Yes - As we guessed - server 2003.

    Server 2003 network stack when it gives you the best route it will give you 127.0.0.1 whatever sangoma sends or not.

    This is why we changed this behavior. So for server 2003 and xp os. make sure that if the gateway is on the same machine you will input 127.0.0.1

    We did this change in V10 to secure media server and its media streams from RTP Injection. RTP injection is the process where an attacker can change the rtp streams and redirect your audio to his sockets thus listening to your conversations. The V10 Media server will disallow this and changes must be made strictly via negotiation. This is why V10 is strict to receive media streams from the promised IP:pORT that the device has specified in the sdp.

    Contact me via email - nb@3cx.com. I want to talk to you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    Re: Incorrect sourceRTP Stream**3RDPARTY PBX SPAMMING MEDIAS

    Thanks to Nicky for taking time to get the Sangoma working. My understanding is he will have a new 3CX generated config file out to make the Sangoma card work properly.

    :D
     
  17. ledemari

    Joined:
    May 17, 2011
    Messages:
    2
    Likes Received:
    0
    hELLO

    I´m facing the same problem when using Uplink SIP to skype on the same box as 3cx

    The connection works fine but I just got audio out, no incoming audio from uplink, checking out the logs I got the error for incoming RTP in 127.0.0.1 port. Any ideas?
     
  18. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    IP's must be the same on both sides - 3CX and sangoma. if sangoma is installed on the local machine and the host is server 2003 or XP you need to put 127.0.0.1.

    Problem is this - if you put 192.168.0.5, when windows calculates best route (on server 2003 or xp) it will not send 192.168.0.5 but 127.0.0.1.

    Media server says "But you promised me in the sdp and in the configuration in 192.168.0.5 - why are you changing this now? No I wil not accept this for security purposes - Bye". And no audio problems appear.

    So if you work around this by instructing the device to send the correct ip address immediately, windows will have nothing to calculate and will not change the ip for you because it is already done.

    Let me know if this works for you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. ledemari

    Joined:
    May 17, 2011
    Messages:
    2
    Likes Received:
    0
    done that. although Uplink tool keep sending 127.0.0.1 instead of the 192x.
    See the logs:

    16:28:19.765 [MS105000] C:13.2: No RTP packets were received:remoteAddr=192.168.1.46:8000,extAddr=0.0.0.0:0,localAddr=127.0.0.1:7040
    16:28:18.796 [CM503008]: Call(13): Call is terminated
    16:28:14.656 [MS105001]C:13.2(LOCAL):Incorrect source of RTP stream. expected:192.168.1.46:8000 but received from 127.0.0.1:8000
    16:28:08.406 Currently active calls - 2: [11,13]
    16:28:08.109 [MS105001]C:13.2(LOCAL):Incorrect source of RTP stream. expected:192.168.1.46:8000 but received from 127.0.0.1:8000

    Uplink Registered:
    16:28:07.984 [CM503007]: Call(13): Device joined: sip:10001@192.168.1.47:5070
     
  20. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,096
    Likes Received:
    140
    ok then if uplink is stubborn, do the following

    If you are using v10 latest 10.0.19117.1690

    Go to C:\Program Files\3CX PhoneSystem\Bin or C:\Program Files (x86)\3CX PhoneSystem\Bin depending on OS
    find 3cxphonesystem.ini
    open it
    UNCOMMENT this line
    ;msNoRTPFilter=0

    so it should look like this
    msNoRTPFilter=0

    Save and restart all services.

    If you are not using v10 latest 10.0.19117.1690, take backup, uninstall, install restore and then go to the points above. restart and it should work. Let me know on this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.