Incorrect Time on all phones

Discussion in '3CX Phone System - General' started by jgibbons3, Jun 22, 2016.

Thread Status:
Not open for further replies.
  1. jgibbons3

    Joined:
    May 17, 2016
    Messages:
    14
    Likes Received:
    2
    I have a mix of cisco 504g, 508g and yealink phones. Allprovisioned with my time zone and they are off by 1 hour. I have checked the 3cx server, the time, time zone and auto update for daylight savings are all correct. My ohones are still showing 1 hour behind. I have seen many posts that blame this on Cisco, yet it is also happening on my Yealink phones.

    Any suggestions would be greatly appreciated.

    Jim
     
  2. 3cxoleg

    3cxoleg Support Team
    Staff Member 3CX Support

    Joined:
    Apr 13, 2016
    Messages:
    16
    Likes Received:
    0
    Hello jgibbons3,

    please make sure that you are running latest firmware, and default 3CX Phone System templates on selected phones. If you are running V14, you can always see the latest supported firmware by accessing Management Console >> Phones >> select provisioned phone and click "Upload Firmware".
    Latest supported firmware for Cisco SPA504G, Cisco SPA508G is 7.6.1
     
  3. jgibbons3

    Joined:
    May 17, 2016
    Messages:
    14
    Likes Received:
    2
    I am using the default templates and the latest firmware. Any other suggestions?
     
  4. 3cxoleg

    3cxoleg Support Team
    Staff Member 3CX Support

    Joined:
    Apr 13, 2016
    Messages:
    16
    Likes Received:
    0
    For Cisco phones you could try and download this .zip file (which contains updated Cisco templates): http://downloads.3cx.com/downloads/misc/ExtendedServices.14.zip
    After unzipping it you'll find templates in folder "ExtendedServices\Templates\", copy and paste them into "C:\ProgramData\3CX\Instance1\Data\Http\Templates\phones" by replacing existing template, then reprovision selected Cisco phones via Management Console >> Phones >> Reset & Reprovision.
    Please make sure you have correct "Time Zone" set. You can check this by accessing Management Console >> Extensions >> Phone Provisioning. After any changes your phone should be reprovisoned.
     
  5. Frank D

    Frank D New Member

    Joined:
    Oct 6, 2014
    Messages:
    215
    Likes Received:
    6
    Hi,

    did you check the time zone settings directly on the phones, via the webinterface? Maybe your provisioning is not working or there is a typo in the template.
    But it sounds like a general problem (with your server or your network):

    Try to access you NTP server from a PC (in the same VLAN using the same DHCP server as the phones). What does it show? Maybe they access a different server or the time on the server is not configured correctly.

    Maybe you configured your system that the daylight saving time is substracted two times, once on the server and once on the phone, but I am not into NTP configuration,
    Look at the PCAP (e.g. log via phones) and look at the NTP traffic.

    Best regards Frank
     
Thread Status:
Not open for further replies.