Increase the length of digital receptionist recordings?

Discussion in '3CX Phone System - General' started by Scottie Holden, Jul 21, 2017.

Thread Status:
Not open for further replies.
  1. Scottie Holden

    Joined:
    Jun 19, 2017
    Messages:
    7
    Likes Received:
    1
    I have a client that plays recorded messages involving their real estate listings to callers. We have this setup through digital receptionists and the recording is changed once a week or so. Often, the recording is stopped before they have finished their list, and it appears to be capped at 2mins. Where/how can I increase this timeout?
     
  2. Scottie Holden

    Joined:
    Jun 19, 2017
    Messages:
    7
    Likes Received:
    1
    I had found that previously and I did increase that value, but it only seems to affect voicemail messages being left. When recording a greeting or message for an IVR, the recording still stops at 2 minutes.
     
  3. ivank

    3CX Support

    Joined:
    Jan 4, 2017
    Messages:
    54
    Likes Received:
    5
    Scottie, what version are you using?
    Have you restarted IVR service after changing MAXVOICEMAILDURATION?
     
  4. Scottie Holden

    Joined:
    Jun 19, 2017
    Messages:
    7
    Likes Received:
    1
    I'm on 15.5. The service has been restarted after the change. The change did affect the length of a voicemail that callers are allowed to leave, but it did not affect the max length of recorded messages that callers hear in the IVR. I have not followed the config change pasted below yet as it did not seem to match what I see in 15.5. Please advise.

    How To Fix It
    The solution is simple. We just need to modify a configuration file to increase this limit to a point where it no longer interferes. To do this:

    1. Open the following configuration file with a text editor:

    %ProgramData%\3CX\Data\Http\Interface\ivr\web.config

    2. Add the maxRequestLength parameter assigning the desired value. For example, to set it to 16Mb and allow recordings of up to approximately 20 minutes:

    <configuration>

    <system.web>

    <httpRuntime maxRequestLength=”16384″/>

    </system.web>

    </configuration>
     
  5. ivank

    3CX Support

    Joined:
    Jan 4, 2017
    Messages:
    54
    Likes Received:
    5
    Please, set logging level to Verbose. Make a test call for each scenario which isn't affected by the new setting.
    Locate c:\ProgramData\3CX\Instance1\Data\Logs\3CXIVR.log, zip it and send to me as a personal message.
    If it's too big, you might want to stop IVR service first, delete the file, start IVR again and repeat the test calls.
     
Thread Status:
Not open for further replies.