Installation Error

Discussion in '3CX Phone System - General' started by HamHam, Jan 18, 2017.

Thread Status:
Not open for further replies.
  1. HamHam

    Joined:
    Jan 18, 2017
    Messages:
    2
    Likes Received:
    0
    Dear All,

    I've been playing with a new install for over 2 days now and every single time after i successfully finish the Debian 8 Setup and logon to the web browser setup section (http://MY_IP:5015) after the HTTP/HTTPS port selection i see a server error, right after the bottom status bar says something about database creation.

    Here is the error:
    System.NullReferenceException: Object reference not set to an instance of an object. at PostInstall.SetupExecutor.WriteIniFiles() at PostInstall.SetupExecutor.CreateDatabase(Action`1 stateChanged) at PostInstall.SetupExecutor.ExecuteSetup(SetupSettings setupSettings, Action`1 stateChanged) at PbxWebConfigTool.PbxSetupService.CreatePbxInternal(SetupSettings settings)

    I really cannot make anything out of it as what's causing the issues other than its something that fails during database setup, i was hoping you guys could shed a light on this.

    I'm installing from debian-8.6.0-amd64-netinst-3cx.iso
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,381
    Likes Received:
    278
    Hello @HamHam
    Once you are at the configuration wizard do you fill out all the values? is there any value that says "Leave Unchanged"?
     
  3. HamHam

    Joined:
    Jan 18, 2017
    Messages:
    2
    Likes Received:
    0
    I fill in all the IP and the FQDN parts, it gets to the screen where it asks me to choose a HTTP/HTTPS ports which i leave as default options 5000/5001 and upon pressing next i get this error.

    One piece of information which i left out before was that i'm doing a virtual install on VirtualBox with the downloaded iso, but i doubt his could have anything to do with the actual cause.
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,381
    Likes Received:
    278
    Check the time of the machine, un-install the PBX and the next install use the command line install not the browser (gives more details about the error) and let us know if that worked
     
Thread Status:
Not open for further replies.