Installation problem version 7.1 on WS 2003

Discussion in '3CX Phone System - General' started by Zoltan, Mar 27, 2009.

Thread Status:
Not open for further replies.
  1. Zoltan

    Joined:
    Mar 27, 2009
    Messages:
    1
    Likes Received:
    0
    Hi,

    When installing the 3CX Phone System version 7.1 on Windows Server 2003, I have received error in the finalize section. Everything seems to be O.K. during the installation process until the "Starting up core services"
    is failed with the error message: Cannot start service 3CXVBoxMgr on computer '.'.
    Can somebody help me? Thanks!

    /Zoltan
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,473
    Likes Received:
    94
    This can happen sometimes if you dont clean up your previous installation correctly.

    Uninstall and use this tool. http://www.3cx.com/support/installation-checker.html
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ixaris

    Joined:
    Apr 29, 2009
    Messages:
    1
    Likes Received:
    0
    Hi,

    I am getting the same error. This is a fresh install in a testing environment. Details are as follows:

    OS: Windows Server 2003 SP2
    Microsoft .NET Framework 3.5 SP1
    IIS
    ASP.net Enabled

    Installation of '3CXPhoneSystem71.exe' fails with error Cannot start service 3CXVBoxMgr on computer '.'.

    Any suggestions please?

    Thks

    Andrew
     
  4. stevenaj

    Joined:
    Apr 30, 2009
    Messages:
    2
    Likes Received:
    0
    Zoltan,

    I have the same error - used a clean Install of Win2K3 with SP2 and IIS with .net 2.0

    Cannot start service 3CXVBoxMgr on computer

    If I uninstall and install with the Cassini webserver it installs OK - there must be an issue with IIS but this release has given me a number of problems - henc why I decided to install on a clean server so I could remove all other issues.

    I hope someone in 3CX can sort this out for us otherwise I will be forced to go back to our Asterisk servers which I had really hoped not to have to do.

    Andy
     
  5. ciscotech2007

    Joined:
    Jan 27, 2009
    Messages:
    94
    Likes Received:
    0
    All old installations (installs on a machine with 3CX installed) must be cleaned up using the 3CX install checker;

    http://wiki.3cx.com/Home/faq/installation-checker

    All new installations (machine that has never had 3CX installed) needs;

    - compatiable hardware
    - latest 3CX server build
    - windows xp sp 2 or supported server edition
    - the selection of IIS or Cassini (IIS PERFERRED)
    - .NET 3.5 (must enable ASP)

    If these conditions are met then you need to go into the IIS management console and make sure IIS has the correct configuration. IIS on XP supports only 1 web site, IIS on servers supports multiple and each need to have the correct configuration of host headers, ports, etc.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,926
    Likes Received:
    241
    HI Andy,

    This is a matter of configuration on IIS or .NET

    As a side note - its fine to use Cassini, especially on machiens with other IIS apps running this is a good option (SBS!)

    We can look into this via a remote login - can you let us know if you are a 3CX partner or a licensed customer?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,127
    Likes Received:
    150
    Hi

    2 questions:

    1) Are you guys able to start the service manually from services.msc?

    2) Is this machine a bit slow? I am asking this because we think this is prone to happen more on slow machines. Any info you can provide on the status of the machine will be of value.

    3) Confirm that this is the only service that did not start.

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. dsuryoputro

    Joined:
    May 6, 2009
    Messages:
    1
    Likes Received:
    0
    Hi, i'm a newbie, I tried to install 3CXPhoneSystem71.exe and experience the same problem, cannot start the core services. Obviously, the problem on the IIS. You mentioned that IIS should have the correct configuration, what is that? could you please share in this forum?

    Thanks and regards
    dsuryoputro

    --------------------------------------------------------
    Re: Installation problem version 7.1 on WS 2003
    by ciscotech2007 on Sat May 02, 2009 7:17 am

    All old installations (installs on a machine with 3CX installed) must be cleaned up using the 3CX install checker;

    http://wiki.3cx.com/Home/faq/installation-checker

    All new installations (machine that has never had 3CX installed) needs;

    - compatiable hardware
    - latest 3CX server build
    - windows xp sp 2 or supported server edition
    - the selection of IIS or Cassini (IIS PERFERRED)
    - .NET 3.5 (must enable ASP)

    If these conditions are met then you need to go into the IIS management console and make sure IIS has the correct configuration. IIS on XP supports only 1 web site, IIS on servers supports multiple and each need to have the correct configuration of host headers, ports, etc.
     
  9. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,926
    Likes Received:
    241
    Can you please try to start the VMbox manager service? It should start normally....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,127
    Likes Received:
    150
    Hi guys
    Go to start / run, services.msc
    Find the 3CX Voicemail manager and start it manually.

    What happened is that there might be a timing issue when starting the Voicemail manager. We will fix this in the next update.

    Then after the service starts all you have to do is open http://PbxServerName/management. The wizard stops completely if a service does not start. But it starts all the other services before stopping leaving just the service that failed. So when you go to services manager you will see that all the other services would have started with success. We will provide a fix for this in the next update of the 3CX VoiP PBX.

    1 question guys - Those of you who had "Could not start service on local computer". Can you please provide me the specs of the machines?
    All I need is processor type, speed and Ram on the machine. The OS should be windows server 2003. Happens only on that platform..

    Before I forget.. "stevenaj", You mentionned that the second time you installed you chose Cassini and you were successful. The second time worked because it is a timing issue. If you chose IIS instead it would still have worked just the same. This problem is not because of the configuration of IIS or the webserver you chose.

    As a side-note I am seeing a lot of IIS (preferred) in the forums (we might also still have left something saying this on our site by mistake. If you encounter this let us know pls so we update).

    IIS was (preferred) in the very first builds we used to make. Now we removed the recommended from the web server selection in the installer because IIS has good things in some scenarios and Cassini is better in other scenarios. We provide both because we know that people can have different needs and services. Benchmarking and statistics at the moment are showing that for example, Cassini performs much better than IIS on a machine that also has other applications that involve IIS as a web server (ex: forefront, exchange, dynamics and sharepoint). Cassini is the best web server for that setup. It also consumes less memory and resources because it is a strip down of IIS. On the other hand IIS has a %age of added performance so if you have a machine that is idle and has no other IIS applications, choose IIS. IIS on windows server 2008 runs very fast if these conditions are met. We will be releasing the results of the benchmarking tests we are doing shortly.

    Let us know if you have further problems..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    667
    Likes Received:
    7
    I have this problem (Voicemail service and 3CX Assistant service cannot start automatically) on all of my installation where I forgot to install NET Framework 3.5 SP1. (but not NET Framework 2.0 as stated in manual!)
    Also it seem to become a problem if you have Windows Server 2003 without SP2 installed.
    Once I have installed NET Framework 3.5 SP1 and started the services manually, them starting OK at next reboot.
     
  12. deanwilliams

    Joined:
    Jul 28, 2009
    Messages:
    2
    Likes Received:
    0
    I have installed 7.1 on server 2003 sp2 with 3.5 SP1

    I have tried this several times using iis and cassini

    Both the assistant and the voicemail manager refuse to start automatically or manually

    Any help would be appreciated

    Dean
     
  13. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,127
    Likes Received:
    150
    If they do not start manually then you should see an error.

    And if the error is not enough go to event viewer and there you should see more detailed information.

    Can you provide this info as well?

    Are you sure you have full updates? Also did you have .net 2 as well before? Or you installed 3.5 SP1 immediately?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. deanwilliams

    Joined:
    Jul 28, 2009
    Messages:
    2
    Likes Received:
    0
    Hi

    I only get a "didnt start in a timely manner" error and only a "timeout error waiting to connect" in event viewer

    Server is up to date with updates

    .net2 was on then installed 3.5 and sp1

    thanks for your help

    Dean
     
  15. DaveIW

    Joined:
    Sep 17, 2007
    Messages:
    19
    Likes Received:
    0
    Same problem here; any news on how to resolve it?

    Cheers
     
  16. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    http://www.3cx.com/forums/3cx-installation-errors-on-vista-server-2008-windows-11512.html

    Applies to 2003 R2
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.