Intercom/Autoanswer w/ 3CX 12.5 SP2 + Polycom IP335

Discussion in '3CX Phone System - General' started by mteague, Dec 4, 2015.

Thread Status:
Not open for further replies.
  1. mteague

    Joined:
    Dec 3, 2015
    Messages:
    10
    Likes Received:
    3
    I'm trying to get paging/intercom requests to autoanswer on Polycom SoundPoint IP335s. I'm still running 3CX v12.5 SP2. IP335s have been updated to latest bootrom and UC software.
    Seems like the ability to have internal paging requests autoanswer w/ the speakerphone hinges on being able to read the alert-info tag in the SIP header. 3CX doesn't seem to be sending this information, though.
    Has anyone else been able to get this to work?
    I've tried many of the solutions posted to this forum and Polycom's w/ no success. Phones just ring when paged.

    Thanks,
    Michael
     
  2. mteague

    Joined:
    Dec 3, 2015
    Messages:
    10
    Likes Received:
    3
    Is there any way to force 3CX to send alert-info in the SIP invite between internal calls?
     
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    We have this working with polycom phones.. Maybe this 335 as a problem?
    Check the rights also .. it could be that the rights do not allow you to page. .. Check extension rights.
    Test like this *9+EXT NUM of polycom..
    Check firmware
    check polycom forums..
    On mine it works and uses alert info with options and in options you have |"Auto answer after 0 seconds" Which means auto answer immediately.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. mteague

    Joined:
    Dec 3, 2015
    Messages:
    10
    Likes Received:
    3
    It may be the 335. Which Polycom models are you using?
    My extension is allowed to intercom, but any extension I page rings instead of auto-answers. It's the same behavior whether I single out an extension w/ *9 or dial a 3CX-configured paging group.
    Firmware on my phone and the one I'm trying to test page are both updated to the latest version.
    I've spent a huge amount of time digging through Polycom's forums and documentation. All the solutions on the Polycom forums use alert-info, which is not being sent by 3CX between internal calls on my system.
    If all the phones were on the same subnet (or I had a switch that supported multicast routing), this wouldn't be an issue and I could bypass 3CX and directly configure all the phones for paging using the built-in settings. I'm trying to get it to work w/ 3CX before buying new hardware, though.
     
  5. mteague

    Joined:
    Dec 3, 2015
    Messages:
    10
    Likes Received:
    3
    nickybrg, could you tell me which model Polycom phones you are using?
     
  6. Aram

    Aram Support Team
    Staff Member 3CX Support

    Joined:
    May 7, 2012
    Messages:
    87
    Likes Received:
    19
    Hi mteague,

    This is fixed in 3CX Phone System V14.
    Please upgrade your system and you will have it working.
     
Thread Status:
Not open for further replies.