Intercom or Paging Delay

Discussion in '3CX Phone System - General' started by fioreit, Aug 30, 2012.

Thread Status:
Not open for further replies.
  1. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    Here's what we're running.
    3CX PRO
    Polycom IP 650 Handsets

    When our Receptionist pages someone from her Phone, the Phone she pages has to Ring Once, then after a couple seconds finally the Intercom is live. All totalled the process takes about 4-5 seconds.
    This is only an issue because our previous PBX (an IWATSU), there was nearly no delay at all. As soon as she Paged someone the Intercom was Live.

    Is there a way to remove the Ring requirement and thus speed up the process? It seems like some of those options that are controlled by the SIP.CFG file aren't in the 3cx Template for Polycom IP 650's.

    Thanks in advance.
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,311
    Likes Received:
    249
    The Paging feature basically uses Intercom and has to make a connection to every phone in order to happen. We have 60 phones and tested it. It took 10 seconds to connect to all of them. Within the Paging Group setup, is an option for multicast. You use a Multicast IP Address, such as 239.0.0.1:50001 and the phones need to be setup to listen on the same port. Also, the MCast Codec needs to be the same on each device. You might also be able to eliminate 3cx from the equation. If the phone supports receiving a multicast page, then it can also make a multicast page, using a button or menu selection.
    See if this helps:
    http://support.polycom.com/global/documents/support/technical/products/voice/Group_Paging_and_PTT_FP62327.pdf

    As far as strict intercom goes - it is possible a short delay will occur because the phones need to connect, but you should not be getting a 4 second delay. Why not just ring the persons extension instead and if they are available they will answer. We used to use Intercom all the time. I convinced them to ring the extension instead and haven't told anyone about the Intercom feature.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    Paging really isn't what we're doing. This is a small office. Our Receptionist answers most incoming calls to our main line. Then she Intercoms the recipient of each call to see if they want to take it or not. It's an old way of doing things, but it's how they like it.

    It's the Intercom Process that has the 4 or 5 second delay between her pushing the button on her console that dials *9123 , and her being live on the other persons phone.

    It's a simple sacred cow issue. Changing phones was already a big enough shock, now making them change how they all get their calls would simply be unacceptable.

    The intercom works, it's just annoying. Just trying to keep our Receptionist Happy.
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,311
    Likes Received:
    249
    Sorry - your title was not clear on what direction you were actually heading.
    What happens if she hits # after the enters the*9xxxx - as the send command - does that help?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    I have her setup with a Sidecar attached to her phone, and its programmed with Custom Speed dials to everyone in the office with the Intercom code *9 and their extention. So all she has to do is hit that. She doesn't have to manually enter *9ext every time.

    Manually entering *9ext# on these phones you still have to hit Dial, or the speaker button or pickup the handset to send the call. And adding the # doesn't seem to speed it up.

    I think this issue is simply a Polycom and 3CX compatibility issue.
     
  6. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    True. What Craig was suggesting was that with many phones, the "#" can act as a send key thereby eliminating the need for someone who uses programmed keys needing to hit dial, send or waiting for the timeout to occur.

    I do not think Polycom supports using # as a substitute for "dial". If it did, then Craig's suggestion would speed up the process by eliminating the time that your person spends pushing various buttons, but not the communication and answering aspect itself. I assume she always uses the dial button and does not wait for a timeout period.
     
  7. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    All she has to do is push the button on the sidecar next to the persons name. The Phone then places the call automatically. She doesn't have to Hit Dial or Pickup the Handset.

    I think the real thing causing the Delay is the Ringtone on the Phone of the Person she's Intercoming to. When anyone does an Intercom Call, the phone has to play a ringtone. I'd like the phone just to beep and pickup. I think that would speed things up quite a bit.

    Is there any way to modify the programming so that the Phone uses something other than the Polycom Standard Ringer for Intercom Calls?
     
  8. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    It would appear that this problem was corrected by upgrading to verson 11.
     
  9. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,311
    Likes Received:
    249
    Thats good to know - and thanks for letting us know. So often we make recommendations in the forum and we never hear back from the op.
    ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    What else did you change on your polycom's to get the paging to work instantly? I have 650's and 550's on version 11 but when we page the phone has to ring one time before the intercom opens up. Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. fioreit

    Joined:
    Apr 6, 2012
    Messages:
    23
    Likes Received:
    0
    I didn't have to change anything else. Just upgraded to v.11, and the v.11 SP1

    Dialing *9ext now the phone being called briefly beeps and then the intercom is on.

    What UC Software are your Polycom's running? Mine are working on both UC 3.3.4 and 4.0.2. I'm also using the 3cx generated provisioning scripts. If you are self provisioning the phones, that may be why it's not working.
     
  12. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    im on 3.3.4.0085

    I am provisioning the phones from the system. If I intercom now the polycom phone rings one time then the speaker phone opens up.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    I use v11 as well and when I hit the paging extension I only get one beep and paging is active no ring, no delay. Have you updated to the newest version of v111?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    I am on SP1 of 11. The problem I think is at the phone. We can page to cisco handsets immediately. The polycom handsets have always functioned like this.

    Can I get a copy of one of your provisioning files to compare?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    This works now after I upgraded the 4.0.2b on the polycom firmware and switched to the new 4.x provisioning file in version 11.

    I noticed you can easily enable multicast paging from the web interface of the phone, I have tried to enable this via the configuration file but so far have not had any luck. I know what command to use I just cant get the syntax right in the configuration file. Anyone had luck doing this? Enabling multicast paging on the phone via the webpage creates a paging softkey and makes paging very simple for the users. But enabling it on a bunch of handsets manually would get annoying.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    Here is the code from the site.xml file. I just cant come up with any combination in the template that turns on paging mode.

    Code:
    <ptt ptt.address="224.0.1.116" ptt.allowOffHookPages="0" ptt.codec="G.722" ptt.compatibilityMode="1" ptt.defaultChannel="1" ptt.displayName="" ptt.emergencyChannel="25" ptt.payloadSize="20" ptt.port="5001" ptt.priorityChannel="24">
        <ptt.callWaiting ptt.callWaiting.enable="0">
        </ptt.callWaiting>
        <ptt.emergencyChannel ptt.emergencyChannel.volume="-10">
        </ptt.emergencyChannel>
        <ptt.pageMode ptt.pageMode.allowOffHookPages="0" ptt.pageMode.codec="G.722" ptt.pageMode.defaultGroup="1" ptt.pageMode.displayName="" ptt.pageMode.emergencyGroup="25" ptt.pageMode.enable="1" ptt.pageMode.payloadSize="20" ptt.pageMode.priorityGroup="24">
          <ptt.pageMode.transmit>
            <ptt.pageMode.transmit.timeout ptt.pageMode.transmit.timeout.continuation="60" ptt.pageMode.transmit.timeout.initial="0">
            </ptt.pageMode.transmit.timeout>
          </ptt.pageMode.transmit>
        </ptt.pageMode>
        <ptt.pttMode ptt.pttMode.enable="0">
        </ptt.pttMode>
      </ptt>
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.