Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Internal IP address changed

Discussion in '3CX Phone System - General' started by voice11, Jan 17, 2018.

Thread Status:
Not open for further replies.
  1. voice11

    Joined:
    Jul 15, 2016
    Messages:
    48
    Likes Received:
    0
    Hello there,
    I had setup a test lab with V15.5, had couple window clients provisioned which worked fine. I had to restart the computer & now it has a different internal IP address & phones no longer work. Outside facing IP is static but internal seem to keep changing. After reading I un-installed & reinstalled with backup copy...but same thing. I didn't get option for static IP for internal IP. Can someone advise a fix pls? Having to re-provision phones every time computer starts is no fun lol. Thank you in advance.
     
  2. jimbo59

    jimbo59 Member

    Joined:
    Nov 17, 2017
    Messages:
    358
    Likes Received:
    77
    It's pretty easy to change your Windoze or linux to a static IP. Google it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. neville

    neville New Member

    Joined:
    Apr 23, 2012
    Messages:
    226
    Likes Received:
    42
    Is this on windows or Linux? You are using DHCP. Either set a static ip on the 3CX or set a reservation on DHCP for the correct IP address.
     
    voice11 likes this.
  4. voice11

    Joined:
    Jul 15, 2016
    Messages:
    48
    Likes Received:
    0
    Its Debian on Vmware. I have static IP.... even before the re-install. But problem is that static is for external, but my internal IP keeps changing. Before it was 192.168.1.11, now its 192.168.1.8 and I don't find option to change/manually input the internal IP.
     
  5. voice11

    Joined:
    Jul 15, 2016
    Messages:
    48
    Likes Received:
    0
    Thank you neville. I knew it was pretty basic but was looking at wrong places. I was able to reserve IP on the router itself. Changing IP on 3CX didn't really work for me, but that's fine I am able to do what I was trying. Thank you.
     
  6. sip.bg

    sip.bg Active Member

    Joined:
    Nov 7, 2016
    Messages:
    704
    Likes Received:
    220
    Edit the /etc/network/interfaces file with nano or other editor. You should have something like this (for Debian 9 Stretch):

    nano /etc/network/interfaces
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    source /etc/network/interfaces.d/*
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug ens192
    auto ens192
    iface ens192 inet static
        address 192.168.1.100/24
        gateway 192.168.1.1
    dns-nameservers 8.8.8.8
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.