Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

International calls disabled by administrator

Discussion in '3CX Phone System - General' started by djdanster, Aug 20, 2014.

Thread Status:
Not open for further replies.
  1. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    We're trying to call a company in the states (we're based in the UK) and it appears that all outbound US calls (only tried US) are blocked. we can call UK lines fines.

    When calling we get a "call forbidden by administrator" however under Settings > Security > Allowed Country Codes tab, they are all enabled so in theory users should be allowed to phone the number.

    The E164 settings are also configured.

    There are no logs for the call in the Server Activity Log.

    What is going wrong?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    ...and your outbound rules are configured properly? There should be 3CX logs unless the sets internal dialplan is set to block the call being sent to 3CX. The Verbose setting provides a lot more information.
     
  3. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    I changed the log settings so it's picking up more info now.

    L:1.1[Extn] failed to reach Line:10001>>001602530000, reason Forbidden

    That number is when phoning Google CS
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    Was this blocked at one time and then unblocked recently, perhaps requiring a system re-start to take affect?

    Have you tried calls from more than one extension? You don't have the outbound rules set to apply to a certain extension range, do you?

    Did this just start recently?
     
  5. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0

    I have restarted the service, so I that would have updated anything that was stopping it. Still having the issue though.


    tried from my extension and the user who is also having the issue.

    Outbound rules are set to apply to extension 100-900 (only have around 30) so that would cover everybody. However as I stated in the OP, there are no restrictions that I know of for international calls.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    Given the wide range of extension numbers that the outbound rules apply to, I'm surprised that you didn't just leave that blank and let them apply to all.

    Off-hand I can't think of anywhere else that would only block calls to certain regions, although, it has been a while since I waded through the security settings/restrictions.

    Did this, (calls to North American numbers) work for you at one time?
     
  7. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    So I changed it to blank but still same situation.

    Yep calls to US have worked and still do for some phones. I've got 3 extensions that I can confirm work with the US number, however mine and others still do not.
     
  8. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    Starting to think it's related to the phones themselves as when I change my subscriber credentials on my Cisco SPA5045G phone to a colleagues that can call US numbers it still doesn't work.
     
  9. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    Update: the message given does seem to be consistent with a 3cx error.
     
  10. 3CXNP

    3CXNP Support Team
    3CX Support

    Joined:
    Apr 25, 2014
    Messages:
    44
    Likes Received:
    0
    Hi,

    Check your outbound rules, and the order in which they are placed in the table.
    The PBX processes the rules based on a 1st matching, not a best matching rule.

    So if you have calls to 00 being blocked and after that a 001 being allowed, you will not be allowed to make calls to US.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0
    I think our outbound rules are pretty relaxed.

    [​IMG]

    1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50

    Above is what is in the "Calls to Numbers with a length of" box.
     
  12. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    Try creating a rule just for North American numbers. I don't know if you use any prefix digits, this example assumes not.

    Numbers starting with prefix 001

    length of 13

    Route out to trunk group, strip 0 digits

    As mentioned, put this above your general rule.
     
  13. djdanster

    Joined:
    Aug 20, 2014
    Messages:
    13
    Likes Received:
    0

    [​IMG]

    These are the settings I've used. Still blocking me though :(
     
  14. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    the only thing that i can think of is that it is something to do with your e164 settings. I attempted to uncheck (disallow) some regions in the settings, but because I have not set-up anything in e164 (have not had to up to this point), it prevents any changes.
    You might try (just on a temporary basis for testing, after hours) remove all of the settings you have in e164, returning it to the default. See if that makes a difference, if it does, then add the settings back one at a time, doing a test after each change until it starts to fail again.
     
Thread Status:
Not open for further replies.