International Number Format Dialing in Mobile Client

Discussion in '3CX Clients' started by John Kostakis, Aug 29, 2017.

Thread Status:
Not open for further replies.
  1. John Kostakis

    Joined:
    Jul 5, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Guys,

    RE: 3CX 15.5.3849.1 on Linux Server

    Seem to have run into an issue on the 3CX Client on Android and Apple. When dialing numbers in the phone's phonebook that are in an international format the call does not go through.

    So basically if the number is +61211112222 in the phone book and its called the number gets rejected by the SIP provider. Is there a way to strip the +612 and replace it with just 02 ?

    Under settings in E164 Processing Settings the Country code selected is Australia +61 and Remove if same country option is selected.

    Is there a way to strip the International format on the App?


    Regards
    John
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Hello @John Kostakis

    The E164 rules will strip the +61 as this is the dial code of the country you have selected so the number sent out will be 211112222.
    If you need to add a 0 to the number you can do it from the E164 settings and add a 0 under the Add prefix field.
     
  3. John Kostakis

    Joined:
    Jul 5, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Yiannis

    I have already tried That, when I make the call using the app on the mobile phone I just get a recording saying "called number does not exist

    It seems its not stripping the +61 and using it to call which does not work. Is this a bug?


    Thanks John
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    I have tried replicating with your example and it works for me. After you dial the number, navigate to Call Log and check what number is dialled. Also send me a screenshot of your E164 settings and a screenshot of the outbound rule the call is supposed to be following to check for any configuration errors.
     
  5. John Kostakis

    Joined:
    Jul 5, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Yiannis,

    After further testing, i have created a new outbound rule and set the the prefix to be 61 instead of +61. When dialing number 612xxxxxxxx the rule does work. However when changing the rule to +61 and then dialing +612xxxxxxxx the rule does not work. So the issue is the +61 is not being recognised in the rules.

    However i have taken a screenshot of the E164 config as well to check, all seems to look correct, Please confirm.

    Thanks
    John

    [​IMG] [​IMG]
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    As you have mentioned in your first comment you want the number to be formatted from E164 +612xxxxxxxx to 02xxxxxxxxx.
    In order to achieve this you need to enable the option remove if same country so that the +61 is removed and add 0. See the following screenshot.

    2017-08-31_10h26_22.png

    Please note that the number is formatted before reaching the outbound rules. So your outbound rule should be formatted with Prefix 0.
    The way E164 is configured in my example there is no need to strip or add anything in the outbound rules. example below
    2017-08-31_10h29_41.png

    Please try it and let us know if that works
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,754
    Likes Received:
    285
    The + is used by you (in your sets stored numbers) to signify that an international prefix should be used. The E164 rules change that to something recognised as a dial-able number in your area, substituting a suitable prefix for the +. The outbound rules then use that number. They don't want the + , that served it purpose and is no longer needed.
     
  8. John Kostakis

    Joined:
    Jul 5, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Yiannis and Leejor,

    Thanks for your help. What i managed to do to get this working was to completely turn off E164 processing and then setup a new outbound rule to detect the +61. I then stripped the +61 and then prepended a 0 to the call.

    This ended up working and i have applied it to the live outgoing rule setup.


    Regards,

    John
     
Thread Status:
Not open for further replies.