Solved iOS-client problems

Discussion in 'iOS' started by SimWhite, Dec 21, 2016.

Thread Status:
Not open for further replies.
  1. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    I'm tried to test iOS version of 3CX client and it seems not working.

    1. I'm installed 3CX client on my desktop and 3CX client on my iOS device connected to the same extension. When I try to make a call to this extension desktop client didn't ring at all. iOS client rings when iOS-device is sleeping but when I try to answer it's disconnect. On the caller side I get "busy".

    2. I try to use only iOS-client without desktop. The same problem. I can't make a call in both directions with iOS inside the PBX. I can make a call to the outside trunk only.
     
  2. Marios Neophytou

    Marios Neophytou Support Team
    Staff Member 3CX Support

    Joined:
    Mar 1, 2016
    Messages:
    241
    Likes Received:
    12
    Hello,
    Re-register/Re-provision both clients and make sure that both client are on hook.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    Already tried more than 20 times.

    UPD: Interested fact. When I try to call from one iOS-client extension to another desktop-client extension (there is no any more clients connected) there is no any ringer on desktop but I see "In a call" status or caller. And when I close iOS client and put phone to sleep the status of this extension is still "In a call".

    UPD2: It is passed more than 40 minutes and the extension status is still "In a call".

    I use the latest versions of software.
     
    #3 SimWhite, Dec 21, 2016
    Last edited: Dec 21, 2016
  4. Marios Neophytou

    Marios Neophytou Support Team
    Staff Member 3CX Support

    Joined:
    Mar 1, 2016
    Messages:
    241
    Likes Received:
    12
    Hello,

    Can you give me more details?

    1. What is the configuration you currently have on the iOS?
    2. Is your PBX running locally or remote?
    3. What is the Version of your PBX?
    4. Do you have tunnel enable on these extensions?
    5. What transport protocols are you using? (UDP/TCP)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    1. Interface: xxx.3cx.eu, UDP, only secure, enabled push, re-provision, tunnel enabled.
    2. Remote. NATed. Firewall tests passed.
    3. Activated PBX 15.0.60903.0
    4. Yes.
    5. UDP.
     
  6. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,187
    Likes Received:
    77
    when you are remote to your PBX or 4G then you also need 5090 TCP (firewall checker only looks at tcp)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Marios Neophytou

    Marios Neophytou Support Team
    Staff Member 3CX Support

    Joined:
    Mar 1, 2016
    Messages:
    241
    Likes Received:
    12
    Do you have "only secure" on iPhone only? If yes then do so for all of your clients.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    I have both TCP and UDP 5090 ports opened, I use this document for ports forward — http://www.3cx.com/docs/3cx-phone-system-v14-ports/ and I have "only secure" feature activated on both extension. And as I understand "only secure" feature used for voice transmission but we have a problem with signalling.
     
  9. Marios Neophytou

    Marios Neophytou Support Team
    Staff Member 3CX Support

    Joined:
    Mar 1, 2016
    Messages:
    241
    Likes Received:
    12
    Only secure (SRTP) option use for secure your communication. Make sure that you have all the appropriate ports open (9000-9500).
    Is this happening with Normal RTP mode also?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    UDP ports from 9000 to 9500 are forwarded. With the normal RTP mode it seems to be working but I need encrypted calls on public networks.
     
  11. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi,

    I have the same issue with my iOS clients.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. SimWhite

    Joined:
    Dec 19, 2016
    Messages:
    17
    Likes Received:
    1
    I made some tests and it seems the problem is not in iOS clients. As I see the problem with the implementation of sRTP (RTP mode secure only) itself. It didn't work with desktop clients too.
     
Thread Status:
Not open for further replies.