Solved iOS Client Receiving Unsupported 3CX Phone System Message

Discussion in 'iOS' started by techclarity, Nov 16, 2017.

Thread Status:
Not open for further replies.
  1. techclarity

    Joined:
    Nov 14, 2014
    Messages:
    90
    Likes Received:
    36
    We have several clients that are still on 3CX version 15. It looks like they updated the mobile client today and they are now receiving a message stating that "We have detected an old an unsupported version of 3CX Phone System. This client will not run correctly with this version and will stop working all together on 1/1/2018. Please contact your administrator to upgrade 3CX to v15.5"

    Why is this message showing? Isn't version 15 still a supported version? Is there a way to turn this off?
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,447
    Likes Received:
    61
    Hi
    It means they have a V15 with NO service packs applied.
    Minimum requirement is V15.5 SP1.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,447
    Likes Received:
    61
    To keep this topic updated:

    Today we just released 15.2.9.284, which also fixes the confusion generated by the "Unsupported PBX" message - so it will be shown only for PBXs < 15.0.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. techclarity

    Joined:
    Nov 14, 2014
    Messages:
    90
    Likes Received:
    36
    Awesome! Thanks for the update Vali!
     
  5. jed

    jed New Member

    Joined:
    Feb 1, 2010
    Messages:
    133
    Likes Received:
    37
    @Vali_3CX

    What will actualy happen on 1/1-2018 if a customer dont upgrade their v14 PBX to v15.x regarding their SoftPhones on Android / iPhones.. Will they not work at all, or?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,447
    Likes Received:
    61
    Hi Jesper

    Most probably, we'll increase client's minimum supported version to 15 and it will behave as it does now when attempting to connect to a V11 or V12 PBX - will disconnect and show an "update PBX" message.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. LyonAdmiral

    Joined:
    Aug 10, 2015
    Messages:
    50
    Likes Received:
    1
    Our institution is in the same boat, we are running V14 SP3, and we cannot upgrade to V15>, we lose functionality with our current phones which are a mix of Cisco and Polycom phones. What can we do? Is there a way to rollback to the older version of 3CX Client for IOS?
     
  8. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,447
    Likes Received:
    61
    I cannot provide you "the" answer, because I don't have it, unfortunately. Basically, it's a marketing/sales question - my advice is to contact our sales team for more information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.