Iphone 5 doesn't stay connected

Discussion in 'iOS' started by Burdie, Sep 23, 2013.

Thread Status:
Not open for further replies.
  1. Burdie

    Joined:
    Sep 20, 2013
    Messages:
    1
    Likes Received:
    0
    Dear all,
    I have an Iphone 5, IoS7, and Installed 3cxPhone 3.0.41. it works great, for a few minutes, the phone looses connection with the Phone System (10) and I'm not able to receive any calls anymore. Even if I setout a ping from my PC to the phone, to keep the wifi active on the Iphone, It still looses registration.
    Is there a way to avoid this?
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,494
    Likes Received:
    67
    Hi Burdie
    If it loose connection while in the background, that's normal - IOS "freezes" it after few minutes. To avoid this, we implemented Apple's push-notifications support starting with 3CXPhoneSystem v11, so I suggest you to upgrade your V10 and the 3CXPhone.
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,217
    Likes Received:
    89
    Sorry, Vali liked to say from version 12...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. samandar

    Joined:
    Feb 15, 2013
    Messages:
    3
    Likes Received:
    0
    Hello,

    Finally had some time last week, so i upgraded 3cx to V12 on the server.
    Installed the new V12 client on the iphone 5 (ios 7.0.2)
    in or out office is automaticly detected .. nice
    but when the app is on the background it is disconnected from 3cx
    even when i try to call my iphone extention, it does not wake up ...

    My 2 colleagues who are on android stay connected ..
    Any idea ?

    kind regards,
    Stefan
     
  5. cicciocappuccio

    Joined:
    Nov 27, 2013
    Messages:
    4
    Likes Received:
    0
    I've the same problem and, moreover, if I use H3G connection I've one way audio problem. On Android everything is ok.... If I use push to enable tunnel app and after I login with 3cx client I can't receive tha call from queue or my customer was already hangout.... in this way this app is unuseful on IOS. On IOS 7 there's new features that enable multitasking app to work but 3cx iphone app is'nt compiled with new xcode for ios 7...
     
  6. mlump

    mlump New Member

    Joined:
    Feb 24, 2012
    Messages:
    113
    Likes Received:
    0
    cicciocappuccio:
    During my testing i ran into problems with the push notifications while using the 3CX Tunnel on the IOS devices. I ended up registering the iPhone's without the tunnel then the push notifications seem to work. See if you get the one way audio when you do not use the tunnel.

    samandar:
    Sounds like you need to enable the push notifications you can do this under Settings -> 3CXPhone. Also if you are having issues with it while using the tunnel try without.
     
  7. cicciocappuccio

    Joined:
    Nov 27, 2013
    Messages:
    4
    Likes Received:
    0
    mlunp, on wifi connection everything is ok with tunnel.... with H3G (natted IP on 3G network) there's a 1 way audio problem. On Android everything is ok.
    There's another problem with IOS. If 2 or more extensions are connected to a queue, the push notification is sent to first extension only....
     
  8. cicciocappuccio

    Joined:
    Nov 27, 2013
    Messages:
    4
    Likes Received:
    0
    I've done more testing: if I use 3CX for windows with tunnel outside the company everything is ok! if I use 3CX for Android with tunnel inside/outside (wifi or 3G) the company with ring group everything is ok. If I use 3CX tunnel on iphone/ipad after few minutes 3CX tunnel will freeze. in IOS, if connected to ring group everything is ok (until tunnel freezes!). If I use app on android or ios with tunnel both inside or outside the company and the extendion is joined to queue no audio is sent/received! It's incredible!
     
Thread Status:
Not open for further replies.