Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

IPKALL number to 3cx system

Discussion in '3CX Phone System - General' started by elios115, Jan 8, 2012.

Thread Status:
Not open for further replies.
  1. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    is there anyway to link the ipkall DID number to my 3cx system directly without using a third voip provider as in if someone calls my ipkall number, my extension will ring based on the inbound rule?
    it used to work with pbxes.org without any configuration.only link ipkall number to the username and proxy on the ipkall website of pbxes.org and it was all set.
    can anybody guide me please how to do it?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    I just send the number of a ring group (800) through to my DDNS URL. If you have a static public IP, you should be able to send it through to that too. Once you create a VoIP provider trunks for them, put their IP in the General tab as the SIP Server Host name or IP. In the trunks setting, you can set to NOT register, and you can set the destination of the calls as well.

    If I recall, they provide that in their set-up instructions. You will also see it in the 3CX log during an incoming call attempt. If you don' have it correct, the call will be rejected. The 3CX log will, at least, show you if you've got the IPKall end set up correctly (if you get a call). It's just a matter of tweaking it beyond that.

    If you run into trouble, post back.
     
  3. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    i am having problem fiding these instructions and locate their ip address.
    can u kindly provide a detailed illustrated tutorial from any online resource u know.
    thx
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    I really don't have the time to write a detailed guide to setting them up. Create an account with them. Set up the number that they send you as anything, for the time being (201, 800, etc.). Dial the number that you have been assigned by them. If you've done it correctly, so far, you will get an incoming call in the 3CX log, it will show that IP that they are sending from. That's the one to use in your 3CX settings when you create a trunk group.
     
  5. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    ok tnks man
     
  6. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    i tried this method with no luck. couldnt identify any ip address related to any call from ipkall.
    i just receive nottin when i call.
    my ipkall settings included my username in the username field and my external ip in the proxy address.
    any further point?
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    If you are not seeing an incoming call attempt in the 3CX logs, when you dial your IPKall PSTN number (from a landline), then you haven't filled in the proper information, in IPKall, for it to route calls to you. As I recall, and it's been a while since I've gone into my IPKall settings at their end. they only require two things from you, a number (to send to you, which you could set as 800) and the destination (your public IP or URL)+ port. You don't need to be concerned about a user name. Be sure that you have port forwarding set up as per the 3CX recommendations http://www.3cx.com/blog/voip-howto/firewall-configuration-overview/, perhaps you router is blocking something. Run the 3CX firewall checker if you are uncertain.

    Are you using a static IP or a Dynamic DNS service at the 3CX end?
     
  8. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    To receive calls from IPKALL you should be able to receive direct SIP calls, e.g. 800@<your_public_IP_address> configured in IPkall. To do this I've set a dummy provider without registration into the 3CX server using internal address 127.0.0.1 and created DDI/DID numbers as with regular providers, e.g. DID 800 rings group 800, etc. Also possible to use other configured providers with same DDI/DID numbers. Hope this helps.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    Yes..forgot...you also need to enable "allow Direct SIP calls" in the advanced settings of 3CX and put in your Domain Name if you use one, like my3cx.dyndns.org, or the call will be rejected.
     
  10. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    i did setup direct sip calls but to my internal network ip since i dont have a domain name (static ip address). i did not try to make a dummy voip as mentioned.
    my ipkall settings are my extension number as username and my external public static ip address as hostname or ip.
    thx for your replies and help i ll check it out and come back to u
     
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    You really need to set up a new trunk group, you "permit" calls from the IPKall IP in there. You don't have to do anything with DID settings.
     
  12. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Probably, if you use just one number from IPKALL.
    I have several and I needed DID/DDI to forward them appropriately.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    i have no idea why but it never worked. i forwarded it to ringroup 800 through a dummy local voip provider that doesnt need registration with no luck
     
  14. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    You say "it's not working" but you have not said whether or not you even see an attempted incoming call in the 3CX log.
    If you don't see that then your settings in IPKall are incorrect.

    Account type: SIP
    SIP Phone Number: 800 (ringgroup number)
    SIP Proxy: my.dyndns.info (your DynDNS)

    Email Address: your@emailaddress.net
    Password: 1234 (your IPKall password)
    Seconds to Ring before Hang Up: 120 (set high)

    That's all you need to put in IPKall. Post the log of the incoming attempt from the 3CX log. You can XX out part of your DynDNS account name.
     
  15. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    first thank you for your help.
    man everything is right in my settings as well.
    but i m not getting any incoming call log even.it weird
    i have a callcentric account linked to an ipkall number and it is perfectly working with 3CX system.
    my attempt to use ipkall straight to 3cx is to bypass the voip block by my ISP on all voip providers.
    im still suffering with my voip blocked although i tried openvpn with windows static routing to my voip ipaddress using the vpn gateway but it is not working!!!

    Regards,
     
  16. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    Well, this may very well be why you are not seeing the incoming calls, you failed to mention this earlier.

    I'm not sure if changing the port (5060 and similar range) that 3CX, and many other VoIP devices use, would get around that.

    You may be out of luck.
     
  17. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    well even if i use a vpn to go out of the blocked area and all my other providers register as normal, i can still receive no ipkall incoming call log.
     
  18. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    I'm a bit confused, you say you use VPN, and that your provider blocks VoIP, yet your other providers work, how, using VPN?

    I'm sorry, I don't know what else to tell you.

    If you have the correct information in IPKall, then you should see an incoming call attempt in the 3CX log even if you don't have anything else data-filled (it's a direct SIP call), UNLESS, it is being blocked by a router/firewall, or your provider.
     
  19. elios115

    Joined:
    Jan 3, 2012
    Messages:
    28
    Likes Received:
    0
    just to be clear.
    my provider blocks voip therefore none of my providers work with no vpn connection to a remote server.
    if im connected to vpn, of course all my provider will register since my traffic is all redirected to the vpn server which is overseas and therefore my ipkall no forwarded to my callcentric voip provider will work 100% right.
    i thought ipkall might not be blocked by my isp so i tried to make a straight connection from ipkall to my 3cx system without a third party voip provider and it did not work.
    the fact is even with or without vpn, im not getting any log while calling to my ipkall number which is forwarded through the ipkall site setting to 800 ringgroup of my 3cx system dyndns name.

    this is the whole picture.
     
  20. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,126
    Likes Received:
    330
    IPKall is VoIP, so I'm not sure why you would be under the impression that it could avoid the block put on by your provider. If you can get it to work via callcentric using VPN, then it sounds like you'll just have to live with that.
     
Thread Status:
Not open for further replies.