Is 3cx Assistant for v.9 backwards compatible with v.8?

Discussion in '3CX Phone System - General' started by star1, Jul 22, 2010.

Thread Status:
Not open for further replies.
  1. star1

    Joined:
    Apr 7, 2010
    Messages:
    40
    Likes Received:
    0
    We'd like to try out PBX version 9 in our sandbox and on a couple of clients. If a client upgrades to the latest version of 3cx assistant in order to try out the new functionality, can the new client still connect to a v. 8 PBX?

    Thanks,
    Eric Mandel
     
  2. ccochran

    Joined:
    May 20, 2010
    Messages:
    2
    Likes Received:
    0
    Eric,

    I just asked this question of support. The answer is no. When you upgrade to v9 Phone system, your v8 Call Assistant clients will immediately begin opening browser tabs with the message:

    "Your Assistant Client may not be fully compatible.Please update or consult your administrator. Server = 9.0.0.13539 - Client = AssistClient_8.0.11138.0"

    I immediately began receiving help desk calls after the upgrade. I hope this helps.

    Chris
     
  3. star1

    Joined:
    Apr 7, 2010
    Messages:
    40
    Likes Received:
    0
    Thanks.

    On the flip side, can a v9 client connect to a v8 phone system?
     
  4. carolinainnovative

    Joined:
    May 4, 2009
    Messages:
    369
    Likes Received:
    6
    No. The new version significantly changed the protocol - they aren't compatible in either direction.
     
  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    152
    Major versions of phone system and Assistant go together and should not be mixed. 8 go with 8 and 9 go with 9.
    Yes might be a problem sometimes but we are thinking of this and we have implemented the following to make admin's transition to v9 less time consuming.

    a) Direct assistant package inside 3CX Phone System build.
    b) Bulk sending of welcome email that can be sent to all users in the company where they can either download and install the assistant or use the aspx builder to build their own assistant builds with their provisioning file injected inside on the fly. result users sees latest assistant installed plus provisioned with his settings on his desktop.
    c) Improved updating functionality where a package is included in the server which the clients can detect and download locally to upgrade their assistants (NOTE: This should not be done by v8 clients because it may cause some problems in the log run if CRM needs to be used.)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.