Is anyone able to get voipfone.co.uk to work with 3CX

Discussion in '3CX Phone System - General' started by jwmassie, Sep 27, 2010.

Thread Status:
Not open for further replies.
  1. jwmassie

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    Hi all.

    I have searched all forums at 3CX and at http://www.voipfone.co.uk, but i just cant find the help i need.

    I am struggling to get voipfone.co.uk to work with 3CX. I have two UK Geographic numbers which i purchased with the package builder at voipfone.co.uk, when these numbers are called i would like it to go through to 3CX then do the easy part of routing the calls, but i just cant get it to work.

    I think i have tried every combintion with my account details etc, but i am about to give up. I think some people have managed to get it to work looking at this 3CX forum though.

    Thanks for any help! Much appreciated!

    Jon
     
  2. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    I have had Voipfone running for some time with my system.
    Settings as follows:
    Generic SIP provider
    Server hostname: sip.voipfone.co.uk
    Outbound proxy: sip.voipfone.co.uk uses port 5060 in both cases
    Advanced: I do not use STUN, but use a specified IP address as per my WAN connection.

    Is there anything else that you need?

    Kind regards
    Richard
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jwmassie

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    Hi Richard

    Thankyou very much for your help, unfortunately i still couldnt get it to work.

    When i login to the 3CX Management Console, i go to Voip Providers in the left pane, and then Add Provider in the top pane. I then type Voipfone as the name of the Provider. Do i then select Generic Sip Trunk option or the Generic Voip Provider option?

    I then type as you said in the following fields;

    Sip Server Hostname or IP: sip.voipfone.co.uk
    Sip server port: 5060
    Outbound proxy Hostname or IP: sip.voipfone.co.uk
    Outbound Proxy Port (default is 5060): 5060

    When i click next, I then have the following fields to type into;

    External Number:
    Authentication ID:
    Authentication Password:
    Max Simutaneous Calls:

    However i dont know what to type into these. I have tried a lot of combinations. I have these details to do with my account;

    My Voipfone account number: 301****2
    My Voipfone account password: 001**0
    The telephone number which came with my account for free when i set it up: 056*******2
    The two UK Geographic numbers i have purchased: 01691*****0
    01691*****1
    I have also previously purchased two extensions with Voipfone: 200 (with extension password 123456)
    201 (with extension password 987654)

    ARE EXTENSIONS REQUIRED THOUGH, IF NOT I WILL CANCEL THEM TO SAVE ME SOME MONEY.

    So basically all im trying to do is when someone calls one of my UK Geogrphic Numbers, i want Voipfone to get it to 3CX and then let 3CX do is business. The problem is i have tried every possible combination in 3CX to get this to work and all i can get is a busy like tone when the numbers are called. The ports are opened as far as im aware on my router and the firewall is disabled on the computer hosting 3CX. Its all getting very annoying not working, im sure it will work like a dream with the right settings.

    I also tried what you said about the STUN, but didnt really understand it too much. I dont know if i have a WAN connection, i have a router here with the IP address 192.168.1.254. Will this IP address work.

    Thanks again Richard, sorry for the long reply but i really have no idea how to set this one up.

    Kind Regards

    Jon
     
  4. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Hi Jon,
    Hopefully I can help you with this.

    For the external number enter you 01691 external number from voipfone
    authenticaion ID: your voipfone account number
    authentication password: your voipfone password.
    Number of calls: I should put two here.

    A static IP address is allocated by your ISP to your Internet connection. It means that the public Internet address stays the same. I suspect in your case that you have a changing or dynamic IP address. Make sure that you use "stun" in this case. Also, ensure that you have forwarded ports through your router, 5060, 5090, and 9000-9050 and conduct the firewall test. This will ensure that you can use SIP providers connecting over the Internet. Is that OK?

    Kind regards
    Richard
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Jon,
    Sorry you select Generic voip provider.

    Kind regards
    Richard
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jwmassie

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    It still isnt working for me, i have the voip profile setup exactly how you say and it still gives a beeping tone when i ring the number.

    Im starting to think there is a firewall problem now though, im getting

    <23:22:04>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <23:22:30>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <23:22:30>: UDP RTP Port 9001. Response received WITH TRANSLATION 56171::9001. Phase 4-02 check passed with WARNINGS. Some functionality may be IMPAIRED. For more information, please visit http://www.3cx.com/blog/docs/firewall-checker/

    when performing the firewall test. The list goes on with pretty much the same message.

    Is this normal or is this the source of the problem.

    Jon
     
  7. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Hello Jon,
    It needs to forward the RTP port range, and the SIP range. If you like I can come on to the system remotely and have a look. There might be something obvious. Would that help?

    Kind regards
    Richard
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. jwmassie

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    Hi Richard

    I have purchased and put in a place a new router which i believe is much better than the business BT router.

    Its a Netgear DGND3300v2, which also supports QoS, which is good for Voip I believe.

    I have forwarded the corrct ports for 3cx and the ports for Voipfone which you gave me to the PC which hosts 3CX.

    I then rerun the firewall test with the default (preset by 3cx) settings.

    UDP Sip Port: 5060
    TCP Sip Port: 5060
    TCP Tunnel Port: 5090
    RTP Ports range: 9000 - 9049
    STUN Server: stun.3cx.com
    Timeout[ms]: 10000

    When it has finished running it all says.




    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <21:58:14>: Phase 1, checking servers connection, please wait...
    <21:58:14>: Stun Checker service is reachable. Phase 1 check passed.
    <21:58:14>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <21:58:14>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.

    <21:58:14>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <21:58:14>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.

    <21:58:14>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <21:58:15>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <21:58:15>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <21:58:21>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <21:58:21>: UDP RTP Port 9001. Response received correctly with no translation. Phase 4-02 check passed.
    <21:58:21>: UDP RTP Port 9002. Response received correctly with no translation. Phase 4-03 check passed.
    <21:58:21>: UDP RTP Port 9003. Response received correctly with no translation. Phase 4-04 check passed.
    <21:58:21>: UDP RTP Port 9004. Response received correctly with no translation. Phase 4-05 check passed.
    <21:58:21>: UDP RTP Port 9005. Response received correctly with no translation. Phase 4-06 check passed.
    <21:58:21>: UDP RTP Port 9006. Response received correctly with no translation. Phase 4-07 check passed.
    <21:58:21>: UDP RTP Port 9007. Response received correctly with no translation. Phase 4-08 check passed.
    <21:58:21>: UDP RTP Port 9008. Response received correctly with no translation. Phase 4-09 check passed.
    <21:58:21>: UDP RTP Port 9009. Response received correctly with no translation. Phase 4-10 check passed.
    <21:58:21>: UDP RTP Port 9010. Response received correctly with no translation. Phase 4-11 check passed.
    <21:58:21>: UDP RTP Port 9011. Response received correctly with no translation. Phase 4-12 check passed.
    <21:58:21>: UDP RTP Port 9012. Response received correctly with no translation. Phase 4-13 check passed.
    <21:58:21>: UDP RTP Port 9013. Response received correctly with no translation. Phase 4-14 check passed.
    <21:58:21>: UDP RTP Port 9014. Response received correctly with no translation. Phase 4-15 check passed.
    <21:58:21>: UDP RTP Port 9015. Response received correctly with no translation. Phase 4-16 check passed.
    <21:58:21>: UDP RTP Port 9016. Response received correctly with no translation. Phase 4-17 check passed.
    <21:58:21>: UDP RTP Port 9017. Response received correctly with no translation. Phase 4-18 check passed.
    <21:58:21>: UDP RTP Port 9018. Response received correctly with no translation. Phase 4-19 check passed.
    <21:58:21>: UDP RTP Port 9019. Response received correctly with no translation. Phase 4-20 check passed.
    <21:58:21>: UDP RTP Port 9020. Response received correctly with no translation. Phase 4-21 check passed.
    <21:58:21>: UDP RTP Port 9021. Response received correctly with no translation. Phase 4-22 check passed.
    <21:58:21>: UDP RTP Port 9022. Response received correctly with no translation. Phase 4-23 check passed.
    <21:58:21>: UDP RTP Port 9023. Response received correctly with no translation. Phase 4-24 check passed.
    <21:58:21>: UDP RTP Port 9024. Response received correctly with no translation. Phase 4-25 check passed.
    <21:58:21>: UDP RTP Port 9025. Response received correctly with no translation. Phase 4-26 check passed.
    <21:58:21>: UDP RTP Port 9026. Response received correctly with no translation. Phase 4-27 check passed.
    <21:58:21>: UDP RTP Port 9027. Response received correctly with no translation. Phase 4-28 check passed.
    <21:58:21>: UDP RTP Port 9028. Response received correctly with no translation. Phase 4-29 check passed.
    <21:58:21>: UDP RTP Port 9029. Response received correctly with no translation. Phase 4-30 check passed.
    <21:58:21>: UDP RTP Port 9030. Response received correctly with no translation. Phase 4-31 check passed.
    <21:58:21>: UDP RTP Port 9031. Response received correctly with no translation. Phase 4-32 check passed.
    <21:58:21>: UDP RTP Port 9032. Response received correctly with no translation. Phase 4-33 check passed.
    <21:58:21>: UDP RTP Port 9033. Response received correctly with no translation. Phase 4-34 check passed.
    <21:58:21>: UDP RTP Port 9034. Response received correctly with no translation. Phase 4-35 check passed.
    <21:58:21>: UDP RTP Port 9035. Response received correctly with no translation. Phase 4-36 check passed.
    <21:58:21>: UDP RTP Port 9036. Response received correctly with no translation. Phase 4-37 check passed.
    <21:58:21>: UDP RTP Port 9037. Response received correctly with no translation. Phase 4-38 check passed.
    <21:58:21>: UDP RTP Port 9038. Response received correctly with no translation. Phase 4-39 check passed.
    <21:58:21>: UDP RTP Port 9039. Response received correctly with no translation. Phase 4-40 check passed.
    <21:58:21>: UDP RTP Port 9040. Response received correctly with no translation. Phase 4-41 check passed.
    <21:58:21>: UDP RTP Port 9041. Response received correctly with no translation. Phase 4-42 check passed.
    <21:58:21>: UDP RTP Port 9042. Response received correctly with no translation. Phase 4-43 check passed.
    <21:58:21>: UDP RTP Port 9043. Response received correctly with no translation. Phase 4-44 check passed.
    <21:58:21>: UDP RTP Port 9044. Response received correctly with no translation. Phase 4-45 check passed.
    <21:58:21>: UDP RTP Port 9045. Response received correctly with no translation. Phase 4-46 check passed.
    <21:58:21>: UDP RTP Port 9046. Response received correctly with no translation. Phase 4-47 check passed.
    <21:58:21>: UDP RTP Port 9047. Response received correctly with no translation. Phase 4-48 check passed.
    <21:58:21>: UDP RTP Port 9048. Response received correctly with no translation. Phase 4-49 check passed.
    <21:58:21>: UDP RTP Port 9049. Response received correctly with no translation. Phase 4-50 check passed.


    Application exit code is 0




    To me this looks good.

    Ok i also tried the settings you told me for Voipfone to put in a few posts ago but they still dont work for me, with these firewall results.

    If you could access the computer to see what i may be doing wrong i would be more than greatful.

    Kind Regards

    Jon
     
  9. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Hello Jon,
    It looks like ther router is working fine. When would be a good time for you for me to look at the PC? Tomorrow evening would be OK. Please let me have a time.

    Kind regards
    Richard Crabb
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. orange2

    Joined:
    May 16, 2014
    Messages:
    5
    Likes Received:
    0
    Hi - I have configured my VOIPfone trunk using the basic settings, and can make outgoing calls (voipfone do not require the trunk to be registered to make calls) but the 3cx trunk isn't attempting to register at VOIPfone, despite showing as green in the list.

    Any thoughts?

    I am on a fixed IP, and firewall tests all pass....

    Thanks
     
  11. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    You really need to use a supported SIP Trunk provider on 3CX if going to be used for Business as 3CX will not offer any official support and or features may not work.

    You set this up as a trunk not a sip account. go to the provider and advanced tab and select inbound / outbound for registration.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. orange2

    Joined:
    May 16, 2014
    Messages:
    5
    Likes Received:
    0
    I understand that supported sip providers are best, but am trying to avoid porting all our numbers to another host!
    Its a bit of a moan, but given that VOIPfone are sip-compliant, and everything I have ever touched registers to them successfully, I do wish that 3CX wasn't so picky!

    Any ideas as to what editing to the incoming/outgoing settings I might need to do? Not entirely sure where to start!!

    Thanks
     
  13. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Hi

    3CX are not being picky, its more of the provider not wanting to pay for testing.

    3CX charge the provider a fee to test the network and setup templates and if everything goes well, then its deemed supported.

    I doubt Voipfone will pay this fee as they have their own PBX Service.

    We on the other hand, are a supported provider and use the same carrier as voipfone so the porting process will be very easy.

    We are offering FREE Number porting until 1st July 2015.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.