Issue with 2nd remote client (3CX Softphone)

Discussion in '3CX Phone System - General' started by aghcanuck, Apr 1, 2016.

Thread Status:
Not open for further replies.
  1. aghcanuck

    Feb 26, 2016
    Likes Received:

    Running 14.1 SP3.

    Have remote 3CX Softphone working fine behind a double NAT (Cisco 3848 / Linksys). Can dial in / out all works good.

    When I try to run another 3CX Softphone (different extension) on a separate machine I get audio issues.

    I believe it is due to the double NAT issues.

    I found this posting: ... extension/

    Which documents:

    In the 3CX Management Console, go to the “Settings -> Advanced -> Custom Parameters” page and search for the “ALLOWSOURCEASOUTBOUND” parameter. The default value is “0” (disabled). When this parameter’s value is set to “1”, 3CX Phone System will use the IP Address and Port inside the “IP” header of the SIP request instead of the values in the “Contact” SIP Header field provided by the remote extension.
    Where is this parameter in 14.3? This seems to be for an earlier version of 3CX.


    Many thanks in advance.

  2. leejor

    leejor Well-Known Member

    Jan 22, 2008
    Likes Received:
    Double NAT will cause issues, especially with more than one device. Each device will have to have a different local port, but even then, if each device registers with (publicIP/port), those port has to be forwarded to the same port on the local IP on the second router, which pretty much requires the use of a static IP being assigned to the devices.

    That's just for the signalling. Now you have to deal with the audio ports and hoping both routers can keep track of them.

    I've used single SIP devices behind double NAT, with some success, but haven't tried multiple devices. Even then, depending on the routers, you can get issues.
  3. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Jun 2, 2014
    Likes Received:

    Additionally, in V14 the 3CXPhone apps are STUN unaware, so enabling the Tunnel for Remote Extension is pretty much required in mos cases.
    Try enabling the Tunnel and see how that goes.
Thread Status:
Not open for further replies.