Issue with Click to Call Chrome extension

Discussion in '3CX Phone System - General' started by AlainC, Nov 7, 2017.

Thread Status:
Not open for further replies.
  1. AlainC

    Joined:
    Apr 26, 2017
    Messages:
    12
    Likes Received:
    0
    Hi everyone,

    I have looked for a similar thread but to no avail.
    I recently upgraded to 3CX Pro V15.5. My Windows client is up to date and I just did a full uninstall/reinstall.
    I am on Windows 8.1 and using Chrome version 61.0.3163.100

    I installed the 3cx click to call extension and set it up. The phone numbers displayed on my web pages are now underlined and clickable, but I can't see a 3cx icon next to them.

    [​IMG]

    When I click on them, nothing happens at all.
    My colleagues have the same configuration as me, except they are on Windows 10, and it works fine for them.

    I'd add that I have deactivated Skype's click to call settings.

    Any help would be appreciated :)

    Thanks !
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    401
    Likes Received:
    36
    Hello @AlainC

    Click on the '3CX click to call' icon that is located at the top right side of the browser, next to the address bar and then click on options.
    On the new popup window, in the 'Call Via' drop down menu, you can select if the call will be completed using the 3cx client for windows or the web client.
    If you have selected the 3CX client for windows, make sure that the client is open and an account is configured and registered, otherwise it won't work. Hope this is helpful.
     
  3. AlainC

    Joined:
    Apr 26, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Mario,

    Thanks for your reply. But of course everything on this side is set up according to the book, I have selected Windows client and it is running.
    Cheers.
     
  4. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    401
    Likes Received:
    36
    Can you try selecting the web client for the 'call via' option to see if that works or not? If it does, switch back to windows client so we can further investigate.
    Make sure to restart chrome after changing the '3cx click to call' options in order for the changes to take effect.
     
  5. AlainC

    Joined:
    Apr 26, 2017
    Messages:
    12
    Likes Received:
    0
    Yes, I have tried this. When the webclient is selected, I still can't see a 3cx icon next to highlighted numbers.
    When I click on it, it opens a tab which loads a link to the webclient (which never really loads) and doesn't launch the Windows Client.
     
  6. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,406
    Likes Received:
    81
    Hi AlainC,

    The 3CX Icon next to highlighted numbers has been removed from Click2Call. This seemingly harmless feature was causing the formatting of many websites to break and so it was removed. In the new version of Click2Call the only transformation made to numbers on websites is to simply underline them.

    The most minimal and least intrusive way to highlight numbers was found to be to just underline them. Keep in mind that even underlining them is slightly intrusive since if you're working on a spreadsheet with numbers, these numbers get underlined making it hard to work, but a less intrusive way to make this feature is yet to be found, so here we are. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. AlainC

    Joined:
    Apr 26, 2017
    Messages:
    12
    Likes Received:
    0
    Ok thanks for this piece of info Leonidas.

    I hope I'll get it to work though !
     
  8. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    401
    Likes Received:
    36
    Hi @AlainC

    You will also need to make sure that the 3CX Client is the default software for CALLTO and TEL protocols. In order to check this, go to control panel and search for Default Programs>Set your default programs(options may be slightly different in your OS) Here you can select the 3cx client and make sure that in its defaults you have both CALLTO and TEL selected.
     
  9. AlainC

    Joined:
    Apr 26, 2017
    Messages:
    12
    Likes Received:
    0
    Hi,

    Thanks, I tried this but still to no avail :(
    I have installed it on another computer on Windows 8.1 and it works fine.
     
Thread Status:
Not open for further replies.