Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Issue with .NET framework 4.7?

Discussion in 'Windows' started by Jake Colvin, Jul 6, 2017.

Thread Status:
Not open for further replies.
  1. Jake Colvin

    Joined:
    Feb 28, 2017
    Messages:
    11
    Likes Received:
    2
    Yesterday I had a user's machine auto update to .NET framework 4.7. After the update was installed and the machine rebooted, the 3cx client would no longer launch and stay open.

    I remember having an issue with the Microsoft Visual C++ redistributables (needing both 32- and 64-bit versions) when we upgraded to v15.

    I had to uninstall the .NET framework and reinstall 4.6.1 in order to get the client to run.

    Is this a known issue? Client version is 15.0.60903.0
     
  2. 3CXusername

    3CXusername New Member

    Joined:
    Jul 31, 2014
    Messages:
    183
    Likes Received:
    16
    So far no issues with our setup (100+ machines):

    Windows 8.1
    .net 4.7 (upgraded from 4.6.1)
    3CX client 15.0.62928
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Jake Colvin

    Joined:
    Feb 28, 2017
    Messages:
    11
    Likes Received:
    2
    Odd. I uninstalled all of the C++ redistributables and reinstalled - no luck. Was pulling my hair out and finally tried the .NET, works like a charm since then. Hasn't happened on any other machines. I'll keep an eye out.
     
Thread Status:
Not open for further replies.