Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Issues delivering audio between Vlans for external calls?

Discussion in '3CX Phone System - General' started by ZacSC, Oct 31, 2017.

Thread Status:
Not open for further replies.
  1. ZacSC

    Joined:
    Jan 21, 2016
    Messages:
    16
    Likes Received:
    1
    Hello!

    I am having what I think is a pretty strange issue where audio does not work when one of our users is on another vlan (from our phone server) making an external call. From what I can tell our firewall settings are all working right, NAT is working right, the firewall checker works. We are using pfSense as our firewall and I am not having issues with anything else.

    Here is what works:
    Users on any vlan can call each other internally
    Users on our primary vlan can make both internal and external calls
    Users who are connected externally (outside of our network) can make and receive both internal and external calls

    Here is what does not work:
    Users on another vlan (different from our phone server) can make a call, it comes through but there is no audio

    Checking the box on an extension to have the PBX deliver audio fixes this.

    Has anyone seen this before, any idea what might be happening or how I might be able to fix it without checking the PBX deliver audio option?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    It would seem that voice ports have no issue from a vlan to the server (as using PBX delivers Audio confirms). I would place a call that you know has the no-audio issue. Check the 3CX Activity Log to see if there is an obvious reason that the two endpoints are not able to pass the audio ports directly. There may be an error message.
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,358
    Likes Received:
    535
    Hello @ZacSC

    Is the issue only present with users on a different Vlan than the PBX that are trying to make external calls? If so what are you using for calling external numbers? Are you using a sip trunk?
    Also the phones in the Vlan are provisioned as local?
     
  4. ZacSC

    Joined:
    Jan 21, 2016
    Messages:
    16
    Likes Received:
    1
    Hey @YiannisH_3CX

    Yes the issue is only present with people who are on a different vlan than the pbx, seems hit or miss on internal vs external calls.

    We are using a PRI via a Patton gateway for external calling.

    Yes the extensions are provisionsed as local, we are using the 3cx smart phone app in most cases.
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,358
    Likes Received:
    535
    Since you are using a Patton you probably need to enable PBX delivers audio under the Patton settings so the audio from the Patton is handled b the PBX. This way you will not need to enable it under each extension settings that will affect all calls but it will apply only for calls coming externally.
     
  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,379
    Likes Received:
    84
    ZacSC likes this.
  7. ZacSC

    Joined:
    Jan 21, 2016
    Messages:
    16
    Likes Received:
    1
    @NickD_3CX

    That was it, thanks for that link, I never would have thought that I needed to setup a route for the gateway that thing was connected too.

    There was one other thing I had to do which was open the ports the Patton uses for RTP on my firewall, as soon as I did both of those (and I confirmed that I did need both) then it started working.
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,358
    Likes Received:
    535
    Glad to hear the issue is resolved and thank you for sharing your solution
     
Thread Status:
Not open for further replies.