Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Issues with Fortiwifi 90D

Discussion in '3CX Phone System - General' started by christensen143, Jan 20, 2016.

Thread Status:
Not open for further replies.
  1. christensen143

    Joined:
    Jan 20, 2016
    Messages:
    3
    Likes Received:
    0
    Hello Everyone,

    I've spent the better part of the last week pulling my hair out (what little I have) trying to get things working behind a Fortiwifi 90D. I've followed all of the instructions for disabling alg and helpers. I have setup port-forwarding. I have been able to register with the SIP provider and have been able to place calls to and from extensions remotely but keep getting a timeout error every time I try to call an external number. Here is the error:

    20-Jan-2016 15:22:23.029 Call to T:Line:10000>>1517917XXXX@[Dev:sip:42739583@gw.siptrunk.com:5060] from L:1.1[Extn] failed, cause: Cause: 408 Request Timeout/INVITE from local
    20-Jan-2016 15:22:23.021 [CM503003]: Call(C:1): Call to <sip:1517917XXXX@gw.siptrunk.com:5060> has failed; Cause: 408 Request Timeout/INVITE from local

    The X's are to hide my cell number but otherwise can anyone assist?

    Thanks
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,086
    Likes Received:
    64
    If you are able to make calls to remote extensions, the question becomes are you using the tunnel, STUN or fixed IP on the server side? The calls are not using the SIP provider, but if using STUN or a fixed IP, at least imply that port 5060 is forwarded correctly.

    The best way to really see is to do a wireshark capture. The error is indicating that 3CX is sending out the route you selected, but for whatever reason is not seeing the provider respond back; hence the timeout. You can run a capture, and then make a call and analyze the flow to understand what the interface is seeing or not.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    Run the 3CX Firewall Checker, if you haven't done so. Be sure that all tests pass, especially port 5060.

    I assume that you've come across these, or others...

    http://www.3cx.com/blog/docs/disable-sip-alg-on-fortigate/
    http://www.3cx.com/blog/docs/fortigate-80-alg/
    https://forum.fortinet.com/tm.aspx?m=115948
     
  4. jmiller

    Joined:
    Aug 1, 2016
    Messages:
    24
    Likes Received:
    5
    I am also having an issue with my 90D. The 3CX firewall checker fails on port 5060 and 5090 with unmatched mapping. Both inbound and outbound calls work fine. Does anyone have a 90D working and willing to share their config? Thanks!
     
Thread Status:
Not open for further replies.