it takes a long time before the ring starts at outgoing call

Discussion in '3CX Phone System - General' started by coertvc, Feb 27, 2014.

Thread Status:
Not open for further replies.
  1. coertvc

    Joined:
    Jan 23, 2014
    Messages:
    26
    Likes Received:
    0
    Hi all,

    3CX v12, Cisco 525 and Yealink t22, server 2008 on VM, Firewall open from and to the Voip provider on all channels. 3CX only servers the internal 200.9 network. no STUN validation as I state my external IP

    The issue;
    when I pick up the horn of the phone and dail my cell, (as an example) it takes 8 seconds before by I get a ring signal and two seconds later my cell phone starts to ring. (i changed the inter digit time to 2 already)

    27-feb-2014 12:30:53.746 [CM503008]: Call(C:17): Call is terminated
    27-feb-2014 12:30:53.743 Leg L:17.1[Extn] is terminated: Cause: CANCEL from 192.168.200.23:5062 (edit: because I put down the horn again)
    27-feb-2014 12:30:52.085 [CM505003]: Provider:[12Connect] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [12Connect VPBX] PBX contact: [sip:999xx@[myexternalIP]:5060]
    27-feb-2014 12:30:44.039 [CM503025]: Call(C:17): Calling T:Line:10000>>[outgoingnumber]@[Dev:sip:999xx@tel.12connect.com:5060] for L:17.1[Extn]
    27-feb-2014 12:30:43.991 [CM503027]: Call(C:17): From: Extn:200 ("SlaapKamer" <sip:200@192.168.200.9:5060>) to T:Line:10000>>[outgoingnumber]@[Dev:sip:999xx@tel.12connect.com:5060]
    27-feb-2014 12:30:43.991 [CM503004]: Call(C:17): Route 1: from L:17.1[Extn] to T:Line:10000>>[outgoingnumber]@[Dev:sip:999xx@tel.12connect.com:5060]
    27-feb-2014 12:30:43.991 Line limit check: Current # of calls for line Lc:10000(@12Connect[<sip:999xx@tel.12connect.com:5060>]) is 0; limit is 1
    27-feb-2014 12:30:43.991 Call(C:17): Call from Extn:200 to [outgoingnumber] matches outbound rule 'Rule for 12Connect'
    27-feb-2014 12:30:43.989 [CM503001]: Call(C:17): Incoming call from Extn:200 to <sip:[outgoingnumber]@192.168.200.9:5060>
    27-feb-2014 12:30:43.989 NAT/ALG check:L:17.1[Extn] REQUEST 'INVITE' - basic check passed. No information for extended checks

    any thought why the call to start is taking so long, and in what way I can shorten it.

    suggestions are very much appreciated

    regards,

    Coert
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Re: it takes a long time before the ring starts at outgoing

    On the surface it appears as though the 8 second delay is lost between the time 3CX sends and your provider responds.

    27-feb-2014 12:30:52.085 [CM505003]: Provider:[12Connect] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [12Connect VPBX] PBX contact: [sip:999xx@[myexternalIP]:5060]
    27-feb-2014 12:30:44.039 [CM503025]: Call(C:17): Calling T:Line:10000>>[outgoingnumber]@[Dev:sip:999xx@tel.12connect.com:5060] for L:17.1[Extn]

    You need to look at the verbose logs or get a wireshark as the log settings currently in use do not show the background negotiations taking place. It could be that additional authentication was taking place or maybe something occurring with codec and port negotiation. I am inclined to think that the issue is more than likely with the provider given that the 3CX system was able to process the call out to the provider in less than a second.

    You might try calling a land-line phone or two and compare time delays. It could be a normal delay while the provider is busy handling his end of the call to ensure connectivity though the various networks to get to the desired endpoint and perhaps some simply take longer than others. There are a number of other things it could be, but a verbose log may give more insight.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,870
    Likes Received:
    304
    Re: it takes a long time before the ring starts at outgoing

    Have you confirmed that this delay occurs when calling a landline? I often find that calls to mobiles usually come with a much longer delay before ringing even starts, although the delay that you are experiencing is a bit excessive.
     
Thread Status:
Not open for further replies.