ITSP requires Invite via header to have a public IP- How To?

Discussion in '3CX Phone System - General' started by helia, Jun 21, 2017.

Thread Status:
Not open for further replies.
  1. helia

    Joined:
    Nov 1, 2016
    Messages:
    12
    Likes Received:
    1
    We're having an issue with some calls not completing based on how an end carrier transfers calls using a re-invite. I'm told that the via header in the invite must have a public ip.

    Here is an invite fragment from a call initiating from 3CX Phone on ver 15.5

    20 Jun 18:03:10.641/GLOBAL/ser[78068]: RECEIVED message from 216.171.235.98:5060:
    INVITE sip:14168004747@173.193.145.203:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.100.95.24:5060;branch=z9hG4bK-524287-1---aa2a8d3c8d523877;rport
    Max-Forwards: 70
    Contact: <sip:helia@216.171.235.98:5060>
    To: <sip:14168004747@173.193.145.203:5060>
    From: "4037751490"<sip:4037751490@173.193.145.203:5060>;tag=c906bb2a

    The 10.100.95.24 is the internal IP of 3CX.

    How can I get this via header to show the static public ip address of 3cx instead of the private ip address?
     
  2. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    928
    Likes Received:
    147
    PubIPInVIA.JPG

    This would be the 'Options' tab of your SIP trunk....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    YiannisH_3CX likes this.
Thread Status:
Not open for further replies.