IVR problem on fresh install

Discussion in '3CX Phone System - General' started by Vic D'Elfant, Oct 11, 2009.

Thread Status:
Not open for further replies.
  1. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    Hi all,

    We are evaluating the 3CX Phone System for our business and are very charmed by its interface and easy setup. We have added a few extensions and linked those to our Aastra IP phones, and added an outbound number we have with 3rd party VoIP provider to test things. Inbound calls, outbound calls, transferring cals, music on hold... everything works.

    The problem occurs when we try using the voicemail or digital receptionist. We get routed to the voicemail agent and then hear a voice saying "An error quit an IVR session, sorry" - then get disconnected. We activated debug logging and this is what's happening, although I more or less hoped to see a few lines telling what's actually going wrong:
    Code:
    12:22:22.337  [CM503008]: Call(1): Call is terminated
    12:22:16.618  Session 51 of leg C:1.1 is confirmed
    12:22:16.493  [CM503007]: Call(1): Device joined: sip:999@127.0.0.1:40600;rinstance=272de672185ba091
    12:22:16.493  [CM503007]: Call(1): Device joined: sip:3555@sip.thevoipprovider.nl:5060
    12:22:16.478  [MS210003] C:1.1:Answer provided. Connection(transcoding mode[unsecure]):xxxxxxxxx:9000(9001)
    12:22:16.478  [MS210001] C:1.2:Answer received. RTP connection[unsecure]: 127.0.0.1:40610(40611)
    12:22:16.478  Remote SDP is set for legC:1.2
    12:22:16.478  [CM505001]: Ext.999: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Voice Mail Menu] PBX contact: [sip:999@127.0.0.1:5060]
    12:22:16.478  [CM503002]: Call(1): Alerting sip:999@127.0.0.1:40600;rinstance=272de672185ba091
    12:22:16.337  [CM503025]: Call(1): Calling Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=272de672185ba091]
    12:22:16.337  [MS210002] C:1.2:Offer provided. Connection(transcoding mode): 127.0.0.1:7000(7001)
    12:22:16.322  [CM503004]: Call(1): Route 1: Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=272de672185ba091]
    12:22:16.322  [CM503010]: Making route(s) to <sip:100@xxxxxxxxx:5060;user=vmail>
    12:22:16.322  [MS210000] C:1.1:Offer received. RTP connection: xxxxxxxxx:19740(19741)
    12:22:16.306  Remote SDP is set for legC:1.1
    12:22:16.306  [CM505003]: Provider:[3rd party VoIP provider] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [xxxxxxxxx] PBX contact: [sip:3555@xxxxxxxxx:5060]
    12:22:16.306  [CM503001]: Call(1): Incoming call from xxxxxxxxx @(Ln.10000@3rd party VoIP provider) to <sip:100@xxxxxxxxx:5060;user=vmail>
    12:22:16.291  [CM503012]: Inbound out-of-office hours rule (unnamed) for 10000 forwards to VM:100
    We're running the latest version of 3CX Phone System on a fresh install of Windows Server 2008 R2, with Desktop Experience and all enabled. Any clues?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,374
    Likes Received:
    231
    I've seen a number of people have issues running servers without having Windows Media Player installed. Will your system play regular audio files without any problems?
     
  3. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    Media Player is installed, it's part of the Windows Server Desktop Experience feature so that should be okay. Others sounds come through just fine; the on hold music, conference management, and the actual error message itself of course. Playing audio on the server works, except for the lack of an actual sound card because it's a server :)
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,374
    Likes Received:
    231
    A download and install of this...http://www.free-codecs.com/download/K_lite_codec_pack.htm has been recommended in the past for this problem.
     
  5. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    I have installed it (already did in fact, but I picked the Full version this) time, rebooted the server but the mysterious error persists, unfortunately.

    We really appreciate your help, by the way. I just wish there was some option to reveal the actual error, but even verbose logging doesn't display what's actually going on.
     
  6. regomotiv

    Joined:
    Sep 15, 2009
    Messages:
    52
    Likes Received:
    0
    any solution or ideas to solving this problem?
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,374
    Likes Received:
    231
    I meant to ask...is this a version 7 or the new 8 .
     
  8. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,406
    Likes Received:
    81
    Just as another thing to try:

    Start Menu > Programs > K-Lite Codec Pack > Configuration > fddaudioshow audio decoder : Direct Show Control Tab
    Go to the Direct Show Control Slider and Put it to the Lowest Setting. Give the PC a restart and retry.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. regomotiv

    Joined:
    Sep 15, 2009
    Messages:
    52
    Likes Received:
    0
    for me, its v8
     
  10. regomotiv

    Joined:
    Sep 15, 2009
    Messages:
    52
    Likes Received:
    0
    v8 for me, I used 2008 R2 x64 w IIS = IVR error, no outbound calls, inbound is ok
    next, I installed v8 on Win 7 x64 with Cassini, inbound & outbound are fine

    both installs were tried on Hyper-V vm's (the host is 2008 R2 x64)
     
  11. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    I set it to "unlikely" (I guess that's what you meant by "Lowest", the next option disables it completely), rebooted the server but to no avail. Just like the others, we're using v8 as well
     
  12. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    Leonidas,

    Seeing that we're not the only one having this problem and because it's of a pretty serious nature (we get clients asking what the voice is about if we don't get the phone in time): would it be possible to report this issue to 3CX staff so it can be investigated? We would be happy to provide any details you may need if it helps in solving this problem as soon as possible. The issue is going beyond the point of being just a minor inconvenience, sadly enough.
     
  13. regomotiv

    Joined:
    Sep 15, 2009
    Messages:
    52
    Likes Received:
    0
    after speaking to 3CX support, 2008 R2 is not production "ready"
     
  14. seetarc

    Joined:
    Aug 29, 2008
    Messages:
    45
    Likes Received:
    0
    We are having similar "An error coding IVR session Sorry" on a Production Server. This was installed "licensed" and commissioned two days ago. Running okay but now we are having error with the Digital Receptionist saying "An error coding IVR session Sorry".

    I have restore from backup - Does not resolve
    I have un-install 3CX and re-install 3CX with good backup and still having issues. This is running on WinXP Pro and its latest 3CX ver8.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    What one calls "is not production ready" is up for debate, of course, but the thing that strikes me most is that there's no actual way of pinpointing what is going wrong. I'd rather see some cryptic error message in the debug log than having no error message at all, because no error message also means that 3CX devs can't possibly know what's going wrong by reading this topic, either. Or at least not with certainty. Seeing that seetarc is having the same problem - or at least the same outcome - on WinXP Pro, I'm led to believe that this isn't a problem which is specific to Server 2008 R2 and therefore would really appreciate someone looking into this.
     
  16. jim@itstod.se

    jim@itstod.se New Member

    Joined:
    Apr 7, 2008
    Messages:
    100
    Likes Received:
    0
    I just had a similar problem after an upgrade that I found was caused by a corrupt xml file with Cassini settings.

    The file C:\Documents and Settings\All Users\Application Data\UltiDev\Cassini\CassiniMetabase.xml should look like this:

    Code:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <CassiningMetabase xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
      <Application FrameworkVersion="2.0" KeepRunning="true">
        <PhysicalPath>C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\</PhysicalPath>
        <Port>5481</Port>
        <Name>3CX PhoneSystem Web Configuration</Name>
        <Description/>
        <DefaultDocument>index.aspx</DefaultDocument>
        <ApplicationID>7abee8ec-5ffa-45f4-b881-6441d5b7c1e9</ApplicationID>
      </Application>
      <Application FrameworkVersion="2.0" KeepRunning="true">
        <PhysicalPath>C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\ivr\</PhysicalPath>
        <Port>5484</Port>
        <Name>3CX PhoneSystem IVR Interface</Name>
        <Description/>
        <DefaultDocument>ivr_start.aspx</DefaultDocument>
        <ApplicationID>7abee8ec-6cca-45f4-b881-6441d5b7c1e9</ApplicationID>
      </Application>
      <Application>
        <PhysicalPath>C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\myPhone\</PhysicalPath>
        <Port>5000</Port>
        <Name>3CX PhoneSystem myPhone</Name>
        <Description/>
        <DefaultDocument>index.aspx</DefaultDocument>
        <ApplicationID>7abee8ec-5ffa-23f4-b881-6441d5b7c1e9</ApplicationID>
      </Application>
    </CassiningMetabase>
    Hope this helps.

    Regards,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    Cheers. It's worth mentioning that we use IIS on our system, by the way.. should've done that in the first post :)
     
  18. danj

    Joined:
    Oct 26, 2007
    Messages:
    16
    Likes Received:
    0
    Hi,

    If you haven't found the IVR logs yet you can find them in the following default location:

    C:\Documents and Settings\All Users\Application Data\3CX\Data\Logs\

    I'd also be curious if the 3CX application pool is set in the IVR website (IIS Website - IVR - Home Directory tab)?

    Regards,
    Dan Jennings
    ____________
    Deerfield.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. Vic D'Elfant

    Joined:
    Oct 11, 2009
    Messages:
    24
    Likes Received:
    0
    Annnnnnnd bingo! You pointed me in the right direction, danj. The 3CXIvrServer.log log was riddled with the following errors:

    Code:
    10:05:03.235|1888|(0):Error! Module '3CX.com.vxi'. Error ID 203. urihttp://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=999&IVRHandlerTO=999&ISID=From_101_To_999_Menu_999_%230%2F0
    10:05:03.238|1888|.\api\VXIpromptImpl.cpp(212):IvrDll, VXIpromptImpl::Impl::Queue(), Error! A serious error within IVR session
    12:27:36.880|0976|(0):Error! Module '3CX.com.OSBinet'. Error ID 219. URLhttp://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=EndCall&IVRHandlerTO=xxxxxxxxxx&IVRSubject=p%3DCANCELLED&ISID=From_101_To_090076467833_Menu_EndCall_%230%2F1MethodGETError-1
    12:27:36.880|0976|(0):Error! Module '3CX.com.OSBinet'. Error ID 204. rc2
    12:27:36.880|0976|(0):Error! Module '3CX.com.vxi'. Error ID 203. urihttp://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=EndCall&IVRHandlerTO=xxxxxxxxxx&IVRSubject=p%3DCANCELLED&ISID=From_101_To_xxxxxxxxxx_Menu_EndCall_%230%2F1
    12:27:36.882|0976|.\api\VXIpromptImpl.cpp(212):IvrDll, VXIpromptImpl::Impl::Queue(), Error! A serious error within IVR session
    12:28:19.720|1304|(0):Error! Module '3CX.com.OSBinet'. Error ID 219. URLhttp://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=EndCall&IVRHandlerTO=xxxxxxxxxx&IVRSubject=p%3DCANCELLED&ISID=From_101_To_090076467833_Menu_EndCall_%230%2F2MethodGETError-1
    12:28:19.720|1304|(0):Error! Module '3CX.com.OSBinet'. Error ID 204. rc2
    12:28:19.720|1304|(0):Error! Module '3CX.com.vxi'. Error ID 203. urihttp://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=EndCall&IVRHandlerTO=xxxxxxxxxx&IVRSubject=p%3DCANCELLED&ISID=From_101_To_xxxxxxxxxx_Menu_EndCall_%230%2F2
    12:28:19.722|1304|.\api\VXIpromptImpl.cpp(212):IvrDll, VXIpromptImpl::Impl::Queue(), Error! A serious error within IVR session
    The URL kinda got me wondering so I tried copying and pasting it in the browser and voila, a timeout. It took a bit of investigation but then I remembered that we have restricted the IIS iplisten table to one public IP address only, which obviously doesn't match "localhost". Adding 127.0.0.1 to the list and having the ivr website bind to 127.0.0.1 fixed the error and everything is working as it should.

    Thanks everyone for your assistance, and danj for the long-awaited pointer to the logs dir :)
     
  20. seetarc

    Joined:
    Aug 29, 2008
    Messages:
    45
    Likes Received:
    0
    Just to update you all. I opened up a case with 3CX and they were very deligent to troubleshoot this issues with us. What i noticed during the troubleshooting was that we could not manage the 3CX PBX via the Web interface although we could manage it via the "Windows Management Consle". The support staff had to re-install the Cassini Web Server "UltiDevCassiniWebServer2" which resolved this first problem and probaly the IVR issues too. I guess the Cassini Web Server was corrupt.

    Now going to the issue of the IVR. When we did our welcome voice recording we placed it on the desktop and then went into the Digital Receptionist, under Prompt we browsed to file on the desktop click "Open", then "Apply" then "OK". When 3CX support Rep went under the folder C:\Documents and Settings\All Users\Application Data\3CX\Data\Ivr\Prompts the greeting file was not present there. We manually copied the file over from the desktop to the above path and all is okay. Like i said the first issue might have resolved the IVR issues but it will be wise to check this path "C:\Documents and Settings\All Users\Application Data\3CX\Data\Ivr\Prompts" and be sure that your IVR recordings are present there.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.