IVRDONOTCALL not applying?

Discussion in '3CX Phone System - General' started by Bob Henderson, Jun 14, 2017.

Thread Status:
Not open for further replies.
  1. Bob Henderson

    Joined:
    Mar 15, 2017
    Messages:
    6
    Likes Received:
    0
    Just setting up our paging units, and the plan was to use the IVRDONOTCALL parameter to make sure no one could mistakenly get into paging.

    However, when I add the test extension in there, I can still call from the IVR both internally, and with an external client.

    I'm on 15.5, the debian install. Do I need to restart services or something for it to apply? Or is there another suggestion these days for how to do a non-dialable extension from external callers?
     
  2. cometmth

    Joined:
    Jun 28, 2017
    Messages:
    7
    Likes Received:
    3
    Hi Bob, did you get this resolved? I am also having this issue. I've tried blocking calls to our paging unit using IVRDONOTCALL but external callers can still call them by entering the extension number in the IVR. I've also tried setting a forwarding exception for the paging extension to end calls from 0000000000-9999999999, but that isn't working either. I'm also on 15.5 on Debian.
     
  3. TC-MagazineK12

    Joined:
    Jul 22, 2017
    Messages:
    7
    Likes Received:
    5
    The IVRDONOTCALL parameter does not work with V15+. I had issues with people having the ability to call in to paging groups or extensions such as classrooms... Not cool. Additionally 3CX wanted more money just for tech support. But a little detective work and recognition of regular expressions yielded a fix/solution.

    Ready for something that does fix this issue? IVR_DIRECT_DIALING_GRAMMAR is simply a regular expression. Adjust that parameter to suit your needs and restart the services, or easier just restart the server.

    As an example the below regular expression, aka what is set for IVR_DIRECT_DIALING_GRAMMAR, disables the ability to dial extensions 2400 and 2500 while still recognizing four digit extensions:

    ((?!2400|2500)[0-9]{4})

    Another example if you want to disable all direct dialing all together use the below to recognize only one digit between zero and nine :

    [0-9]{1}
     
    #3 TC-MagazineK12, Jul 22, 2017
    Last edited: Jul 22, 2017
    Pyrognome and cometmth like this.
Thread Status:
Not open for further replies.