Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

let 3CX reply with 401 instead of 407 at register?

Discussion in '3CX Phone System - General' started by MartinSavelsberg, Feb 26, 2013.

Thread Status:
Not open for further replies.
  1. MartinSavelsberg

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Hello,

    Is it possible to let the 3CX reply with 401 instead of 407 after the first register attempt from a UA?
    The UA is an Ericsson SIP-gateway that only accepts 401 as reply.

    Thanks in advance.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    From what I've come across, 401 should be returned by the device that terminates the request, the Registrar Server or User Agent Server (UAS). While 407, should be returned by an intermediary proxy, to challenge a request to authenticate, before they forward it to the destination server. So..3CX being a server, I would have expected it to reply with a 401. I'm assuming you've found that to not be the case?
     
  3. MartinSavelsberg

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Indeed, 3CX replies with 407. However 401 as reply by 3CX is expected and requested in this case. Ericsson softswitch that tries to register on the 3CX accepts only a 401 as a reply.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    It sounds like it requires an explanation from someone at 3CX, as something does not sound "right". I'm assuming that both devices are on the same network, and that no Proxy is involved.
     
  5. MartinSavelsberg

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Indeed, no proxy in between. But the devices are on different network. This should not be a problem.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    I'm wondering, if the fact that the gateway is on a different network,and because of that, an assumption that there is a proxy in-between, is the cause for a different response, from 3CX.
    Did you ever try using the Ericsson, on the same network?
     
Thread Status:
Not open for further replies.