Linksys SPA3102 - 3CX cannot authenticate inbound call

Discussion in '3CX Phone System - General' started by msymmes, Jan 27, 2012.

Thread Status:
Not open for further replies.
  1. msymmes

    Joined:
    Nov 24, 2011
    Messages:
    17
    Likes Received:
    0
    LinkSys SPA-3102 incoming calls fail if PSTN Answer Delay set to 3 seconds

    I have followed the 3CX guide for setting up the SPA-3102 to the letter. But in order to receive the caller id that arrives in the first few seconds via the Bell 202T modem modulation you must delay the answer.

    So, I will show you successfull inbound call logs when the delay is set to ZERO and then I will show you the authentication failure when the delay is set high enough (3 seconds) to capture the inbound caller id number.

    I presume my issue is with setting up some sort of wildcard/mask for incoming rules but I have tried numerous options without success.

    Any help would be very much appreciated. BTW, My voip provider and DIDS are all working correctly. This analog gateway is installed to supplement the VOIP provider.

    Here are the logs...

    An example of failure when answer delay is set to 3 seconds...
    Code:
    00:12:09.312  [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
      INVITE sip:%3C10700@192.168.1.119 SIP/2.0
      Via: SIP/2.0/UDP 192.168.1.125:5060;branch=z9hG4bK-5f274305
      Max-Forwards: 70
      Contact: "SPA-3102"<sip:4165586275@192.168.1.125:5060>
      To: <sip:%3C10700@192.168.1.119>
      From: "SPA-3102"<sip:4165586275@192.168.1.119>;tag=4a7b115ca0b65edo1
      Call-ID: 838f5d48-abbbaaf1@192.168.1.125
      CSeq: 101 INVITE
      Expires: 240
      Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
      Supported: x-sipura, replaces
      User-Agent: Linksys/SPA3102-5.1.10(GW)
      Content-Length: 0
      Remote-Party-ID: SPA-3102 <sip:4165586275@192.168.1.119>;screen=yes;party=calling
      
    00:12:09.312  [CM302001]: Authorization system can not identify source of: SipReq:  INVITE <10700@192.168.1.119 tid=-5f274305 cseq=INVITE contact=4165586275@192.168.1.125:5060 / 101 from(wire)
    00:11:40.928  Currently active calls [none]
    00:11:10.926  Currently active calls [none]
    00:10:38.924  Currently active calls [none]
    00:10:25.127  [CM503003]: Call(131): Call to sip:200@pbx.rsti.ca has failed; Cause: 487 Request Terminated; from IP:192.168.1.113:3412
    00:10:25.029  [CM503008]: Call(131): Call is terminated
    00:10:12.540  [CM505001]: Ext.200: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [snom-m9/9.5.7-a] PBX contact: [sip:200@192.168.1.119:5060]
    00:10:12.539  [CM503002]: Call(131): Alerting sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6
    00:10:12.396  [CM503025]: Call(131): Calling Ext:Ext.200@[Dev:sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6]
    00:10:12.395  [MS210002] C:131.2:Offer provided. Connection(transcoding mode): 192.168.1.119:7280(7281)
    00:10:12.371  [CM503004]: Call(131): Route 1: Ext:Ext.200@[Dev:sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6]
    00:10:12.370  [CM503010]: Making route(s) to <sip:200@192.168.1.119:5060>
    00:10:12.369  [MS210000] C:131.1:Offer received. RTP connection: 192.168.1.125:16414(16415)
    00:10:12.367  Remote SDP is set for legC:131.1
    00:10:12.366  [CM505002]: Gateway:[Analog Outbound] Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA3102-5.1.10(GW)] PBX contact: [sip:10700@192.168.1.119:5060]
    00:10:12.363  [CM503001]: Call(131): Incoming call from 10700@(Ln.10700@Analog Outbound) to <sip:200@192.168.1.119:5060>
    00:10:12.345  [CM503012]: Inbound out-of-office hours rule (unnamed) for 10700 forwards to DN:200
    00:10:12.344  Looking for inbound target: called=<10700; caller=10700
    00:10:12.340  [CM500002]: Info on incoming INVITE:
      INVITE sip:%3C10700@192.168.1.119 SIP/2.0
      Via: SIP/2.0/UDP 192.168.1.125:5060;branch=z9hG4bK-450b7316
      Max-Forwards: 70
      Contact: "SPA-3102"<sip:10700@192.168.1.125:5060>
      To: <sip:%3C10700@192.168.1.119>
      From: "SPA-3102"<sip:10700@192.168.1.119>;tag=2043379dd602dee2o1
      Call-ID: b3291679-4d9d2db6@192.168.1.125
      CSeq: 102 INVITE
      Expires: 240
      Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
      Proxy-Authorization: Digest username="10700",realm="3CXPhoneSystem",nonce="414d535c0532c2b495:62e039a7a22f2fe1ecefca70d7ac6edc",uri="sip:<10700@192.168.1.119",algorithm=MD5,response="776c4d3e2d681462bca89670c673d97d"
      Supported: x-sipura, replaces
      User-Agent: Linksys/SPA3102-5.1.10(GW)
      Content-Length: 0
      Remote-Party-ID: SPA-3102 <sip:10700@192.168.1.119>;screen=yes;party=calling
    
    And then an example of success when answer delay is set to 0 seconds...

    Code:
    00:10:25.029  [CM503008]: Call(131): Call is terminated
    00:10:12.540  [CM505001]: Ext.200: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [snom-m9/9.5.7-a] PBX contact: [sip:200@192.168.1.119:5060]
    00:10:12.539  [CM503002]: Call(131): Alerting sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6
    00:10:12.396  [CM503025]: Call(131): Calling Ext:Ext.200@[Dev:sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6]
    00:10:12.395  [MS210002] C:131.2:Offer provided. Connection(transcoding mode): 192.168.1.119:7280(7281)
    00:10:12.371  [CM503004]: Call(131): Route 1: Ext:Ext.200@[Dev:sip:200@192.168.1.113:3412;transport=udp;line=3mdqy6]
    00:10:12.370  [CM503010]: Making route(s) to <sip:200@192.168.1.119:5060>
    00:10:12.369  [MS210000] C:131.1:Offer received. RTP connection: 192.168.1.125:16414(16415)
    00:10:12.367  Remote SDP is set for legC:131.1
    00:10:12.366  [CM505002]: Gateway:[Analog Outbound] Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA3102-5.1.10(GW)] PBX contact: [sip:10700@192.168.1.119:5060]
    00:10:12.363  [CM503001]: Call(131): Incoming call from 10700@(Ln.10700@Analog Outbound) to <sip:200@192.168.1.119:5060>
    00:10:12.345  [CM503012]: Inbound out-of-office hours rule (unnamed) for 10700 forwards to DN:200
    00:10:12.344  Looking for inbound target: called=<10700; caller=10700
    00:10:12.340  [CM500002]: Info on incoming INVITE:
      INVITE sip:%3C10700@192.168.1.119 SIP/2.0
      Via: SIP/2.0/UDP 192.168.1.125:5060;branch=z9hG4bK-450b7316
      Max-Forwards: 70
      Contact: "SPA-3102"<sip:10700@192.168.1.125:5060>
      To: <sip:%3C10700@192.168.1.119>
      From: "SPA-3102"<sip:10700@192.168.1.119>;tag=2043379dd602dee2o1
      Call-ID: b3291679-4d9d2db6@192.168.1.125
      CSeq: 102 INVITE
      Expires: 240
      Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
      Proxy-Authorization: Digest username="10700",realm="3CXPhoneSystem",nonce="414d535c0532c2b495:62e039a7a22f2fe1ecefca70d7ac6edc",uri="sip:<10700@192.168.1.119",algorithm=MD5,response="776c4d3e2d681462bca89670c673d97d"
      Supported: x-sipura, replaces
      User-Agent: Linksys/SPA3102-5.1.10(GW)
      Content-Length: 0
      Remote-Party-ID: SPA-3102 <sip:10700@192.168.1.119>;screen=yes;party=calling
    So what do I need to put in the inbound rules section that might patch this up - even just a workaround.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    There is something wrong in your configuration of SPA3102. Why don't you reset it to factory default and set it according manual configuration guidelines from 3CX blog ?

    We had installed probably over 1000 pcs of SPA3102 and never had any problems. It is probably the best gateway in the market for the past 5 years.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    286
    I don't think is is inbound rules as it is not even getting that far.

    Can you post the PSTN LIne tab details, from your device?

    One thing that I'm a bit curious about...you are using port 5060 for the FXO port.
    Being a two port device, 5060 normally defaults to the FXS port and 5061 to the FXO. In 3CX, at least in the past, it has been port 5062 that was the default for the FXO port of a 3102 trunk.

    Which requires that the FXO port be changed to 5062 in the 3102.
     
  4. msymmes

    Joined:
    Nov 24, 2011
    Messages:
    17
    Likes Received:
    0
    I did change the port from 5062 (as per the 3CX manual setup steps) to 5060 just out of desparation.

    I will try a factory reset and type in the settings again. I think I will delete the PSTN gateway in 3CX and recreate.

    And attached is the PSTN line tab html page...
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. msymmes

    Joined:
    Nov 24, 2011
    Messages:
    17
    Likes Received:
    0
    By factory resetting the SPA3102 with "73738#" and then following the 3CX blog instructions for this device and deleting the PSTN Gateway and adding it back, I was able to make this device work. I have set the answer delay to 4 seconds (and will try 2 seconds) and I am receiving the caller id Number.

    Outgoing calls also work okay.

    Just one major problem... The incoming callerid (calling number) is not being passed to my cordless DECT 6.0 M9 phone (which by the way is a very nice product IMHO). However it is being passed to my Snom 300 and my Gransstream GXP2000.

    So now I guess it is time to dig into the M9 setup because I am getting caller ID displayed on the M9 when a call arrives at 3CX via my voip provider.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. msymmes

    Joined:
    Nov 24, 2011
    Messages:
    17
    Likes Received:
    0
    Okay, so the caller id no showing up on the M9 is not an M9 phone problem. The 3CX server log shows me that the SPA-3102 passes the Remote-Party-Id to 3CX if it receives a callers NAME. If it only receives a caller's number then it passes "SPA-3102" as the incoming caller's name. To bad it does not just pass the caller's NUMBER in the case where there is no NAME.

    So maybe it is time to look at the SPA-3102 configuration manual unless anyone has a better idea.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    286
    I suspect that your problem was because of the * in the VoIP caller ID pattern. This came up in the past and when 3CX still had the manual configuration listing for the 3102 and a note added regarding it. I have never put anything in there and never had an issue.

    By the way, I've found that 3 seconds is the minimum answer delay setting (North America)if you still want to capture the caller ID.

    This link...

    http://forum.snom.com/index.php?showtopic=5997

    ...seems to indicate that the caller Id issues, you are having, with the M9 handset may be firmware related.

    The 3102 will send what ever name you have assigned it if there is no name sent with the number. You can force a name by putting the number, and a name you choose, in the 3CX phonebook.

    I see you have both Line1 and the PSTN set to use port 5060. I would leave Line 1 with 5060, even though you don't use it right now. Change the PSTN port to 5061 or 5062 and change the 3CX trunk settings to match. This will allow you to use the FXS port in the future without having to remember to change the port numbers later on.
     
  8. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    790
    Likes Received:
    45
    Correct your settings at the PSTN Line tab as leejor mentioned:

    SIP Port: 5061 or 5062 (5062 preferable)
    fill Dial Plan 8: (S0:<10700>) (don't forget ">")
    remove the “ * ” at VoIP Caller ID Pattern
    place the “ * “ at PSTN Caller ID Pattern

    This should do the trick.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    286
    Don't put the * in any Caller ID Pattern field, just leave them blank.

    Because the 3CX on-line set-up guide for the 3102, had said to put it in there it caused a lot of grief for new users in the past. Try without first, you can always add it later if you feel it necessary.
     
Thread Status:
Not open for further replies.