Linksys SPA921 No Audio

Discussion in '3CX Phone System - General' started by mosesmosheh, Jan 16, 2010.

Thread Status:
Not open for further replies.
  1. mosesmosheh

    Joined:
    Jan 16, 2010
    Messages:
    6
    Likes Received:
    0
    Hello,

    I have a central office running the PBX machine. It is behind a NAT, however, I have opened all of the ports recommended to the PBX Machine. I have run the firewall checker on the PBX machine, and it reports all is well.

    In remote office, I have a Linksys SPA921, configured according to the guide on the wiki pages, using External IP address of the PBX Machine for the Proxy.

    The problem is the Phone registers fine from the remote location on the PBX Machine, and is able to make calls, however it cannot receive calls
    and there is no audio exchanged.

    I installed the 3CXPhone (Softphone) on a workstation here, and it can connect, register, send and receive voice packets to an extension in the remote location. I am presently only using Extension to Extension calls.

    I have read through the forums, and followed various peices of advice but nothing worked. The handset, when on the LAN at the remote location works well.

    Any advice would be greatly appreciated.
    Sam
     
  2. mylove4life

    mylove4life New Member

    Joined:
    Jan 7, 2010
    Messages:
    165
    Likes Received:
    0
    I'd be guessing this is a outbound rule problem. Have you checked them?
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    So, no incoming calls and no audio on outgoing? If that is the case then the "remote" router isn't able to get packets through to the set. It is either blocked by the router or, more likely, 3CX doesn't know how to reach it. If you check the 3CX logs just after the 921 is powered up (when it does a registration) you should see the public IP AND the local port of the 921. It's like mailing a letter to an apartment building address with no apartment number on it. With out both it won't be able to get through. Since the 3CX softphone worked then it is probably not something the remote router is blocking, unless you were using tunnel mode, then there is still a possibility that it is a router problem.

    Do you have STUN datafilled and enabled on the 921? That is usually the biggest problem when trying to get an external extension working. Also, make sure that there is no other device on the remote LAN using the same port number you have assigned on the 921, the default is usually 5060.
     
  4. cullenr2

    Joined:
    Jan 12, 2010
    Messages:
    1
    Likes Received:
    0
    I've been going around in circles for the last couple of weeks trying to get two external SP942s to talk to one another. There is loads of talk about using the 3cx tunnel, but I just want a phone to talk via NAT through a firewall to the internet to a firewall and then NAT again to the 3cx server.

    If your sure, really sure that you have got all your firewall and phone settings right. And the phones register and you can make phone ring. But you just have no audio. Everyone says it's firewall problems, but just click on an extension in the 3CX console click on the "Other" tab and just make sure the "PBX Delivers Audio" tick box is ticked.
     
Thread Status:
Not open for further replies.