Linksys SPA922 phones restarting, again and again

Discussion in '3CX Phone System - General' started by pierre.bln, Mar 21, 2011.

Thread Status:
Not open for further replies.
  1. pierre.bln

    Joined:
    Nov 15, 2008
    Messages:
    20
    Likes Received:
    0
    Hi,

    We have 3CX 9 with all recent updates. 7 Linksys SPA922 with firmware as advised on the support pages (6.1.5a).

    Yet, since the update to V9, some phones frantically restart every 20s. It's basically random: a phone will be "sick" for 24 hours, then back to normal. With only 7 phones, we always have at least one in a "continual restart" loop every business day.
    The only good side is that they stop restarting when on a call...

    I have of course tried everything, reprovisionning, restarting, reseting to factory defaults... we are on the default provisioning template in 3CX, and the phones are corretly getting the provisioning files (eg changing ext name works). I am using POE but triple checked and we are far away from the max power draw (plus nothing changed since V8).

    Does anyone has a tip as to where I should look into?

    Thanks,
    Pierre
     
  2. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    It might be keep alive messages. if your keep alives are to short and not getting through then the phone will reboot as it thinks that the system is not there. It sounds like you might have a network issue or two. It would be best to run some wireshark captures and post it here so we can try and find out way the phone is rebooting.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. robbe

    Joined:
    Mar 6, 2010
    Messages:
    2
    Likes Received:
    0
    Same issue here - Keeps rebooting

    Currently at V10 beta. Phone connects without any problem but keeps rebooting to do a firmware upgrade.

    I disabled the upgrade in the template like this:

    <Upgrade_Enable group="Provisioning/Firmware_Upgrade">No</Upgrade_Enable>


    but it keeps provisioning with the option enabled.
     
  4. robbe

    Joined:
    Mar 6, 2010
    Messages:
    2
    Likes Received:
    0
    Sorry after changing the template the reboot stopped. Did'nt wait long enough for the phone to recieve the new template

     
  5. pierre.bln

    Joined:
    Nov 15, 2008
    Messages:
    20
    Likes Received:
    0
    Thanks Robbe, I actually just yesterday had finally found the solution, and although we used different means, our common issue was obviously this update function.
    What I did on my side was deactivate the "reboot after upgrade attempt" option (or something like that).

    But that really leaves me with a doubt: there is something unclean in my setup (the phones were unsuccessfully trying to update, thus rebooting), I actually just discarded the symptom, but the phones are probably still trying to update behind.
    Does anybody know what the phones were trying to (unsuccessfully) update?

    My 3cx update folder contains no firmware update file for the SPAs, just the 1 language file I use.

    Maybe I should include all languages files though I don't use them (they are listed in the SPA template), or include an firmware file there where the SPA would say: "Ok, I am up to date with 6.1.5a, I don't need to update"...
     
Thread Status:
Not open for further replies.