Solved Local IP address

Discussion in '3CX Phone System - General' started by heusd045, Oct 19, 2017.

Thread Status:
Not open for further replies.
  1. heusd045

    Joined:
    Sep 27, 2017
    Messages:
    8
    Likes Received:
    0
    Hello, I am having a discussion with my SIP trunk supplier about a missing dial tone. They looked at a Wireshark trace and they say that in the attached screenshot they should see our public IP address and not a local IP address.

    Can you please tell me which setting I have to change in 3CX so the external IP address is used?

    Thank you
     

    Attached Files:

  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,486
    Likes Received:
    358
    Hello @heusd045

    Is this a supported provider? You can force the Public IP address to be sent by navigating to the Options tab of the PBX and under the option "Select which IP to use in 'Contact' (SIP) and 'Connection'(SDP) fields" select "Use this IP Address" and fill in you public IP.
     
  3. heusd045

    Joined:
    Sep 27, 2017
    Messages:
    8
    Likes Received:
    0
    Yes, this is a supported provider.

    Under the option "Select which IP to use in 'Contact' (SIP) and 'Connection'(SDP) fields" I have selected "Use this IP Address" and filled in our public IP but still the local IP shows up in the Wireshark capture.

    3CX is running on a virtual machine. Could this be causing the problem?
     
    #3 heusd045, Oct 19, 2017
    Last edited: Oct 19, 2017
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,486
    Likes Received:
    358
    Can you send me the capture in a p.m. so i can check where the issue is? Can you also describe your issue you are facing in case something else is causing it?
     
    santhosh likes this.
  5. heusd045

    Joined:
    Sep 27, 2017
    Messages:
    8
    Likes Received:
    0
    How can I p.m. you?
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,486
    Likes Received:
    358
    Click on my username and you should see the option start a conversation. Once you click on that a new private conversation page will open. Upload the capture to a web transferring service and send me the download link
     
  7. Gioal

    Joined:
    Nov 9, 2017
    Messages:
    10
    Likes Received:
    2
    I have the same here, SIP Trunk configured, checked to change SDP IP address but 3CX still sending local IP address.
     
  8. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    837
    Likes Received:
    127
    Have you tried the Update 2 beta? This might be related to the bug that was fixed per the changelog

    Code:
    Fixed “Public IP in SIP Via Header” where the Bye message contained the PBX Local IP Address in the SIP Via Header.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Gioal

    Joined:
    Nov 9, 2017
    Messages:
    10
    Likes Received:
    2
    You are correct, after update the SDP is with correct address. Thank you very much.
     
Thread Status:
Not open for further replies.