Long Distance Restriction

Discussion in '3CX Phone System - General' started by tecskw, Jul 7, 2015.

Thread Status:
Not open for further replies.
  1. tecskw

    Joined:
    Nov 7, 2013
    Messages:
    6
    Likes Received:
    0
    Good Day,

    I've seen many posts regarding restricting calls unless you use 777 with the pin which I've managed to do if I'm restricting any phone from outside calls.

    What I am trying to configure is the following:
    1. All phones can dial locally *using North American Dialing rules* - Also they are not using 9 to dial out, they can dial straight out using 7 digit telephone number.
    2. Only two phones are not restricted from making Long Distance, the remaining are
    3. The remaining phones to use PIN to complete long distance call.

    What I've been able to accomplish
    1. Confirmed all sets can dial out locally and long distance as normal
    2. Created a LD Restrict group and added members to that group that are now allowed to dial LD unless a code is used
    3. Created outbound rule with that group included
    4. Confirmed when attempting to dial locally from one of those members, the call goes through, when attempting to dial Long Distance, call fails which is what I want.
    5. When attempting to dial 777 and enter pin, I still receieve cannot dial out long distance.
    6. When setting PIN Protect and removing member from LD Restrict Group, outbound calls are allowed however will not allow local dialing.

    I just need to be able to have my phones dial locally but restricted from using LD unless using a code....that is where I am stuck.

    3CX V.12
    Licensed for 8 simultaneous ports
    2 x Patton 4Port FXO Analog Gateways supporting 6 Analog Trunks
    Mixture of Yealink T46 and T38 IP sets.

    I am sure this is something easy to rectify and probably in the provisioning tables but drawing blanks on where to look.
     
  2. Charles_3CX

    Charles_3CX New Member
    3CX Support

    Joined:
    Jul 6, 2015
    Messages:
    114
    Likes Received:
    4
    Hi, How have you got your outbound rules configured. Check to see what is set up in your "Apply this rule to calls" section for the outbound rules.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    Could it be something to do with the order in which you have your Outbound rules?

    Keep in mind that rules are "read" by 3CX from top to bottom, so if you have a restriction rule similar to, or can also be interpreted by a "general", or "catch-all" rule later, then you must place that rule higher in the list. The first match encountered, will be followed.
     
  4. tecskw

    Joined:
    Nov 7, 2013
    Messages:
    6
    Likes Received:
    0
    Guys thanks,

    Will check out your suggestions next time I am onsite.

    Will attached screen shot of outbound rules if I haven't resolved.

    Regards,

    Kevin
     
  5. tecskw

    Joined:
    Nov 7, 2013
    Messages:
    6
    Likes Received:
    0
    Been awhile since I've been able to revisit this but I've just had a few other customers that are now wishing for the same Long Distance requirements.

    I've attached my outbound rules, and I've successfully been able to block LD calls by dialing 1+ and make LD Calls dialing 9+ for those that it pertains to.

    I am still however banging my head against the table with dialing LD 1+ and then having to enter PIN to allow the call to go through.

    I do have a group called LD Restrict and the same Outbound Rule which doesn't have a route to go out, basically "block all calls", I need to get past that part by using 777 + PIN. Is it possible to enter 777 plus a wildcard for the PIN, in the prepend??

    Need more coffee!!
     

    Attached Files:

  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,255
    Likes Received:
    63
    If I understand what you want to do correctly, you want all extensions to be Locked with a PIN, but required to enter the PIN ONLY if they are dialing a Long Distance number, for the Local Calls not to have to enter the PIN.

    If this is the case, unfortunately the PIN Protect option in the Extension Settings applies for any external call made, you can't somehow set it to be needed only for Local Calls.
     
  7. tecskw

    Joined:
    Nov 7, 2013
    Messages:
    6
    Likes Received:
    0
    Nicky_D,

    That's exactly what I am trying to accomplish!

    Looks like I will have to have the Telco company put a block on their end and provide a code to use.

    I will make a note to add this request to the "request" section of 3CX then.

    Regards,

    Kevin
     
  8. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    384
    Likes Received:
    52
    Here's what I would do. Restrict LD with the outbound rule as you know how to do (3, 7 or 10 digit numbers only).

    Now make an outbound rule where they have to dial a prefix of the PIN code(s) you want to use

    e.g. user dials (PIN CODE) and (Long Distance Number) as one string and send the call through stripping the prefix.

    You can do this with one PIN code outbound rule that is shared or multiple. Multiple pin codes is doable but more work. If one PIN code you can change it from time to time and notify the users of the new PIN code.

    E.G.

    Prefix/PIN code 1234, phone number 1-416-123-4567.

    Outbound rule prefix is 1234, strip digits is 4.

    User dials 123414161234567 and the system handles the rest.

    It is actually easier to use this way than the 3CX PIN protect because user accomplishes this in one step.

    You may wish to remove redial memory from the phones with long distance to prevent others from figuring out the ld codes.

    I'm also in north america and while I haven't used this for long distance calls I have setup similar for international calls and it works great.

    Users dialing 011 get denied and users dialing PINCODE+011 go through all done with outbound rules.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. tecskw

    Joined:
    Nov 7, 2013
    Messages:
    6
    Likes Received:
    0
    Lifeline,

    Thank you very much, this works perfectly.

    Regards,

    Kevin
     
Thread Status:
Not open for further replies.