Loop component

Discussion in 'CRM / Helpdesk / App Integration' started by Michaelhal, Apr 20, 2012.

Thread Status:
Not open for further replies.
  1. Michaelhal

    Joined:
    Nov 18, 2011
    Messages:
    8
    Likes Received:
    0
    Hi ,

    I am trying to create a record component where the user records audio then playback that audio , after this i got a user input component and a conditional component where 1 = continue and 2 = re-record. this all is packaged in a loopcomponent.

    now i have created a project variable $Callflow.HasToRecord and set it to true,
    the Loop component condition = HastoRecord

    When the user selects 2 to re-record i assign an variable assignment where i have set HasToRecord to false.

    when i select 1 to continue or 2 to re-record it just keep looping me arround

    i also tryed setting the loop condition to equal HasToRecord.true

    But still it loops me arround

    3cxIVRserverlog shows me : error id 301 on my loop component

    what am i doing wrong here ?
     
  2. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    Can you post your project so I take a look at it? Please, remove credentials if you have them into the project. Or send me a private message with it so I take a look. It will be much easier that way.
    Thanks,
     
  3. Michaelhal

    Joined:
    Nov 18, 2011
    Messages:
    8
    Likes Received:
    0
    Nevermind i created an new project with a loop in it and it worked on the second try i must have done something wrong the first time , ahh well i got it working now no need to waste your time on my project.

    You can delete this topic if you want
     
  4. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    OK, no problem. thanks.
     
Thread Status:
Not open for further replies.