Mediatrix 1204

Discussion in '3CX Phone System - General' started by snook, Apr 12, 2007.

  1. snook

    Joined:
    Apr 12, 2007
    Messages:
    4
    Likes Received:
    0
    I am trying to configure a Mediatrix 1204 PSTN Gateway with the 3CX system. I was successful in configuring it for outgoing calls, however not for incoming.

    I was able to make it work with Asterisk for incoming and I think I know why. In Asterisk you are not required to provide a "password" to authenticate with the gateway, only a username. So I believe this may be the problem because I cannot find any place for a password in the Mediatrix configuration.

    In 3CX, if I go under "Lines -> Manage -> [My External Number]", and then in the "Authentication" section, I put in the "ID", but it forces me to also have a "Password". Is there anyway I can overide this? Perhaps by just going into the Postgres DB and removing it?

    Has anyone gotten a Mediatrix unit (any model) working with 3CX for incoming calls?
     
  2. dyntech

    dyntech New Member

    Joined:
    Mar 28, 2007
    Messages:
    160
    Likes Received:
    0
    I had the same problem with an Audiocodes MP-118 FXO. Although I did not spend too much time with it, I never got it to work.
     
  3. Anonymous

    Anonymous Guest

    For this to work, you can try.

    Required Optional registration (on the bottom of the configuration page for gatweays) select Nothing option.

    In the lines configuration put a user name in the Authentication ID. Leave password blank (it should allow you to do that).

    Internal number use the internal number provided.

    I might be able to help you further if you provide me with a link to the configuration guide of your device.

    You should be able to get this to work we done something similar before see post http://www.3cx.com/forums/viewtopic.php?t=995&start=15 I think it is along the same lines.

    Henk.
     
  4. snook

    Joined:
    Apr 12, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks dyntech & itfarmer, I did eventually get it working.

    The key is setting the correct "realm" in Mediatrix. It needs to be set as "3CXPhoneSystem" or the authentication won't be passed.

    Things don't work 100% yet though. Even though both outgoing and incoming calls are working, all incoming calls are automatically dropping after about 30-33 seconds. I've opened another forum topic regarding this hoping that someone will be able to help me:

    http://www.3cx.com/forums/viewtopic.php?p=3608#3608
     
  5. Anhph68

    Joined:
    Jul 19, 2010
    Messages:
    4
    Likes Received:
    0
    I have a problem with the 3CX and Mediatrix. I can’t call from the Ext.100 (softphone: X-lite) in the 3CX to my mobile, the PSTN line is plugged into the port 1 of the Mediatrx 1204. However, the reverse direction (My mobile or other PSTN line to the softphone) is OK.
    I have tried for a long time, but it hasn’t been successful. Can you give me an advice?
    The following is my network diagram:


    The following file is my report of the test:
    http://www.mediafire.com/?5dw9to4tltpat6x

    Thank you so much!
     

    Attached Files:

Share This Page