Memroy leak in V4 Alpha

Discussion in '3CX Phone System - General' started by mschmidt, Oct 26, 2007.

Thread Status:
Not open for further replies.
  1. mschmidt

    Joined:
    Oct 25, 2007
    Messages:
    8
    Likes Received:
    0
    Yesterday I installed the recent alpha release on my laptop. Just played a bit with the configuration, but didn't connect any devices.

    The 5 services still stay in the background since than. Now I detected that the 3CXPhoneSystem.exe process has a memory allocation of over 1 GB, growing about 10 MB per second with very little CPU time. The other 3cx services behave normally, memory allocation is between 2 and 28 MB.

    There is no VoIP application open on my machine or on the network, nor any configuration page opened in a web browser. Operating system is Win XP Pro SP2, it's a Pentium M machine with 2 GB of RAM.

    I restarted the service, and memory allocation for the process is back on 7 MB, growing very slowly, about 12 KB every 5 seconds or so (without interacting with 3cx in any way).

    Is there any log or trace file I could check to help finding the cause?
     
  2. mschmidt

    Joined:
    Oct 25, 2007
    Messages:
    8
    Likes Received:
    0
    ...and still growing

    Hm, back on > 500 MB memory allocation... and not growing right now, after stand-by.

    @ forum admin: sorry, I overlooked the extra forum for version 4 beta...
     
  3. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Yes, we're aware about that memory leak. Moreover, we've already fixed it. This fix will be available with next upload.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.