Meo/Sapo Voip Provider

Discussion in '3CX Phone System - General' started by lsmr, Aug 18, 2014.

Thread Status:
Not open for further replies.
  1. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    Hi,

    I've been trying to configure my voip account from my internet provider here in Portugal.

    In the past i did register and make calls with my voip provider thought 3cx. Yesterday I start with the actual version of 3cx phone system and I can't do calls and I also can't register.

    I can make calls with xlite software and I'm using this configuration

    host: voip.sapo.pt
    port: 5060
    proxy: proxy.voip.sapo.pt
    proxy port: 5070

    ID: +35130xxxxxxx
    Pasword: xxxxxxxx

    But in 3cx phone system I've been experiencing some errors:

    18-ago-2014 15:06:33.064 [CM504007]: Next attempt to register Lc:10000(@MEO[<sip:+35130xxxxxxx@voip.sapo.pt:5060>]) is scheduled in 120 seconds
    18-ago-2014 15:06:33.061 [CM504005]: Registration failed for: Lc:10000(@MEO[<sip:+35130xxxxxxx@voip.sapo.pt:5060>]); Cause: Cause: 503 Service Unavailable/REGISTER from local


    Registration at MEO has failed. Destination (sip:+35130xxxxxxx@voip.sapo.pt:5060) is not reachable, DNS error resolving FQDN, or service is not available.

    I've been reading manuals and created the generic sip provider but i'm still with no success

    Could you please help me with the right configuration to recieve and make calls?

    Regards,
     
  2. IliasL_3CX

    3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    74
    Likes Received:
    0
    Hi there,

    Thank you for contacting us,

    Have you run the firewall checker? Does it comes up green?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    First I run the firewall checker and everything was red, then I disable the windows firewall, just to try and all come up green.

    After that I checked the activity logs but the still not registered, I restart the system but the error is the same.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    In your trunk settings, have you tried substitution the actual IP addresses, in the event it actually is a DNS resolution issue?

    voip.sapo.pt = 213.13.146.110
    proxy.voip.sapo.pt = 213.13.89.67
     
  5. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    Is the same error:

    Registration at MEO has failed. Destination (sip:+35130xxxxxxx@213.13.146.110:5060) is not reachable, DNS error resolving FQDN, or service is not available.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    Are you sure you are sending them the correct digits?

    Are you able to ping the address from the computer?
     
  7. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    What you mean? The number and password i have is correct, it works on xlite softphone
     
  8. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    Yes I can ping voip.sapo.pt and proxy.voip.sapo.pt
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    Well that would seem to eliminate a problem with your DNS server, that, and the fact it didn't work when using the IP addresses.



    From what i can find, you have the correct settings. Why it would appear you are not getting through, I have no idea, but it may be something on your network. It may also be indication something completely different. Error messages can be like that, sending you off on the wrong tangent

    If possible, i would enlist the help of the provider. If they can, perhaps they can tell you if they are seeing a registration attempt. if they don't, then you've got a network/firewall/configuration issue. if they do, and they are rejecting the registration, they can probably tell you why.

    Have you tried "mixing around" the server and proxy destinations and the port numbers. Thee first thing I would try is eliminating the proxy and just going with the voip.sapo.pt at port 5060.

    I don't know if you have yet posted on the 3CX Portuguese forum. You might have more luck finding a member that is familiar with sapo.pt.
     
  10. lsmr

    Joined:
    Aug 18, 2014
    Messages:
    6
    Likes Received:
    0
    Now it's working!

    I installed in another computer located in another network and internet account. I use the same voip account and same details but this time I keep in blanck or default some configuration fields. Maybe that was the problem, some bad configuration or there is something wrong in the network of my first 3cx instalation.

    I gonna check later, now i can make and recieve call from the 3cx phone system.

    Thank you for your time.
     
  11. pstmg

    Joined:
    Dec 9, 2012
    Messages:
    49
    Likes Received:
    0
    I use SAPO/TELEPAC provider without any problems. If you want I can send you my configs
     
  12. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,246
    Likes Received:
    61
    Are you sure the Authentication ID is correct with the proceeding "+" symbol? Most commonly the Authntication ID only consists of numbers. Try removing the + symbol and also check if by any chance any IPs have been blacklisted in the Management Console.
     
  13. pstmg

    Joined:
    Dec 9, 2012
    Messages:
    49
    Likes Received:
    0
    yes it is ! for some reason this provider requires the use of the '+' in the number for authentication. I use the same provider here for incoming calls
     
Thread Status:
Not open for further replies.