mic needs to be plugged in server!?

Discussion in '3CX Phone System - General' started by psiho, Apr 7, 2010.

Thread Status:
Not open for further replies.
  1. psiho

    Joined:
    Apr 7, 2010
    Messages:
    4
    Likes Received:
    0
    I just started playing with this great peace of software and lost about 2 hours today to configure Skype gateway. I kept getting one-way audio and tried everything I could find on forums but it didn't work. 3cx is installed on my home server running Windows 7, with no monitor or mic/speakers which forced me to use terminal connection so I expected problem is there, but configuring mstsc to leave audio on server did not help.

    Finally my attention went to Skype client on server which was reporting "cannot detect sound card" when I tried echo test. It was wierd as I got audio on output so sound card was there and working. Finally I plugged in a headset in server and started Skype again... the error message went away. Tried a call from my sip extension to my skype account and it worked great!

    My surprise came later when I discovered that headset plugged in my server was broken. Mic was not working. So I plugged in an old mic cable, wit no mic on other hand, no nothing, just dead cable. It worked too! Then I tried disconnecting that cable only to find out one-way audio is back. Connect again and it works. Repeated few times and finally concluded that I have to have dead mic jack plugged in my server for this to work.

    I'm noob at this, and it may be something ordinary for you pros, but I'm quite surprised and am curious about your comments.
     
  2. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    You problem that you use a Terminal Session. You should use another software, like Real VNC, then connect to the server and configure sound devices in Skype as needed. No any relationship with microphone, headset and so on...
     
  3. Montclairguy

    Joined:
    Feb 23, 2010
    Messages:
    68
    Likes Received:
    0
    I don't have any Windows 7 experience, but have heard about various sound issues such as this. It certainly sounds like either the OS or motherboard are enabling / disabling your audio hardware, based upon a connection detection. But, there are considerations when installing / managing the PBX over an RDP connection.

    As long as you're leaving the sounds at the server, it won't interfere with Skype -- unless you're using Skype version 4.2.0.155 or higher, for the first time. Specifically, that revision of Skype has become RDP aware and will change over to the RDP drivers if it detects you've connected to the box that way.

    You need to turn off that RDP support by ensuring you move the RDP driver to the bottom of the list for both mic and speaker devices, in Skype's advanced audio settings. Move your physical audio device to the top of the two lists.


    It's possible that will solve your problem without anything plugged into the jacks.
     

    Attached Files:

  4. psiho

    Joined:
    Apr 7, 2010
    Messages:
    4
    Likes Received:
    0
    @igor ... I dubt that terminal session is the only reason. See more below...

    @Montclairguy... My Skype version is 4.2.0.155
    Audio settings with terminal session set to leave audio on remote server


    ...with terminal session set to bring audio localy and mic too:


    So, simple leaving audio on remote server seems correct without need to move thing up or down, just like installation manual suggested. I don't have time now to play further (and it all works now so it is not important),... to plug out that cable and send you screen-shot of that, or to connect monitor to server and completely bypass terminal services. But if you're curious I can try that tomorrow.
     

    Attached Files:

Thread Status:
Not open for further replies.