Micronet 5050s Gateway Config Problem

Discussion in '3CX Phone System - General' started by PCCENTRE, Feb 26, 2007.

  1. PCCENTRE

    Joined:
    Feb 26, 2007
    Messages:
    5
    Likes Received:
    0
    Micronet FXO Gateway 5050 sip
    Spent all weekend trying to configure the PSTN line on FXO, could not find a solution.

    00:25:47.859 AuthMgr::eek:nAuthFailure: Registration request from sip:282483254@81.193.248.194 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    00:25:47.859 AuthMgr::requestCredential: Message SipReq: REGISTER 81.193.248.194 tid=-45e22909-2bb51-4390 cseq=REGISTER contact=282483254@192.168.0.150:5060 / 2 from(wire) hasn't been authenticated! The result code is 1. Password is '1001'


    Tryed every option, I am missing something simple probley. Have read both guides, still no joy.

    Can anyone assist.
     
  2. Anonymous

    Anonymous Guest

    Have a look at the Sipura 3000 guide that is on this webpage.

    You need two sets of authentication.

    Authentication ID and password must match at both sides (3cx and MicroNet) and can be found under you lines setup (not extention setup). Looking at your message it looks like you got your authentication specifics wrong.
     
  3. PCCENTRE

    Joined:
    Feb 26, 2007
    Messages:
    5
    Likes Received:
    0
    Hi,

    Thanks for the info but I have the information correct i think.
    Have Set as the same 3 digits id and pass as in the line security section under line 1. (in micronet)
    What is the secound one.

    PS
    the hotline on line config I am using the phone number which is the same as Internal Number (Use different range as extension range) in the 3cx line config page.

    Can you see my problem,~

    thanks~
    Paul
    Portugal
     
  4. Anonymous

    Anonymous Guest

    OK.
    ==================================
    Your SIP provider details go under:
    Line Configuration.

    External number: 282483254 (assuming this is your VoIP number given by your provider)
    Internal number: 5 digit number for example 10000
    Allow outbound calls on this line: ticked
    Answer incomming calls on this line: ticked
    Answer after: 0

    Authentication:
    ID: this is the username given to you by your voip provider
    Password: this is the password given to you by your voip provider

    Route inbound calls :
    I configured a ring group but you can sellect an extension that will answer the call.
    ========================================

    On your modem/router/Gateway:

    User ID equals the Authentication ID
    Password equals the Authentication Password.

    =========================================

    ++++++++++++PSTN+++++++++++++++
    Your SIP provider details go under:
    Line Configuration.

    External number: Any number (I use my PSTN number)
    Internal number: 5 digit number for example 10001 (this should be different than the one in the VoIP Config)
    Allow outbound calls on this line: ticked
    Answer incomming calls on this line: ticked
    Answer after: 0

    Authentication:
    ID: 10001 (matching the internal number but is not necessary, I do it this way to keep track of things :))
    Password: what ever you confortable with.

    Route inbound calls :
    I configured a ring group but you can sellect an extension that will answer the call.


    ========================================
    On your modem/router/Gateway:

    User ID equals the Authentication ID (this is a bo bo in the manual)
    Password equals the Authentication Password.

    =========================================

    You need a dial plan, this to make the modem aware that you want to forward the call to a PBX.

    Dial Plan 8: (S0:10001)

    Than tell the modem what dial plan is the default one. Make sure that the default plan points or has (S0:10001) in it.

    Turn of all the other stuff re authentication, you do not want to authenticated PSTN calls I assume as they are incoming.

    If you have a link to a manual (english) of you modem I can have a better look to what is what, but for now the above settings should work.

    All it is, is an authentication issue (which is good) so atleast your modem/gateway is talking to 3cx.
     
  5. PCCENTRE

    Joined:
    Feb 26, 2007
    Messages:
    5
    Likes Received:
    0
    Micronet problem

    Hi,

    Thanks for the info.
    Have followed the manuals and your instructions to the book, still having the same issue.

    Have put a copy of the manual at http://www.netconexion.pt/3cx.html

    Please let me know if you can see the error I am making.

    Thanks,
    Paul
    Portugal
     
  6. PCCENTRE

    Joined:
    Feb 26, 2007
    Messages:
    5
    Likes Received:
    0
    Hi,

    If you can give me an email address I can email the remote access details so you can see the problem.

    Thanks,

    Paul.
    Portugal

    PS if we can solve this we will be buying multi copies for our clients.
     
  7. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Hi Paul

    I am sorry to hear you are having such difficulties. What the issue still ? can you not register ?

    Go into the device set the line number, auth ID and auth Password to a 5 digit number (say 10000) and set the hotline another number (say the telephone number 282483254). Then simply set the external number to match 282483254, and set the rest to 10000.

    If you still have issues let us know what is the error you are getting.
     
  8. PCCENTRE

    Joined:
    Feb 26, 2007
    Messages:
    5
    Likes Received:
    0
    Still Reg Problems

    Hello.

    Thanks for the information.

    Still getting error on reg
    13:03:33.700 AuthMgr::eek:nAuthFailure: Registration request from sip:192.168.0.199 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    13:03:33.700 AuthMgr::requestCredential: User: is not found in database!
    13:03:33.630 ServRegs::eek:nAdd: Registered: Ln:282960960@FXO Gateway
    13:02:52.341 MediaServerConnected: Media Server is connected
    13:02:52.341 ??: SL: connected 125server:0/MediaServer at [125server]/MediaServer
    13:02:50.157 DBA: ** Database connection Ok **
    13:02:50.137 StunClient::process: STUN resolved external IP=81.193.248.194 by server 80.239.235.209
    13:02:49.887 StunClient::process: Send initial STUN request to 80.239.235.209
    13:02:49.787 CallMgr::Stack::thread: ** Enter Stack Loop **
    13:02:49.476 CallMgr::DumThread::thread: ** Enter DUM Thread **
    13:02:49.466 CallMgr::Stack::Initialize: ** Adding transports **
    13:02:49.466 CallMgr::Initialize: ** Initializing SIP stack **
    13:02:49.336 CallMgr::Initialize: Version: 2.0.1361.0
    13:02:49.336 CallMgr::Initialize: Start 3CX PhoneSystem Call Manager
    Any Ideas

    Thanks,
    Paul
    Portugal
     
  9. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,677
    Likes Received:
    18
    This particular gateway is documented step by step in the manual and also we use it internally in our company. If you follow the steps it should work.

    The server status log you posted shows that the authentication details somehow are not correct. Please double check these.

    Note that with this device the lines sometimes appear unregistered, but still its possible to make and receive calls.

    Did you try to place a call? What happened? Can you let us know in detail what happened and post the server status log?
     
  10. Anonymous

    Anonymous Guest

    The manual is back to front (well the bit that is on the internet for 3cx I hope they fix it soon).

    In your case.

    Switch user ID and Authentication ID arround or make them both the same.

    Authentication ID (found where you configure the gateways) must be the same as the line ID you have specified in 3cx same applies for your password.

    Lets have a look:
    Registered: Ln:282960960@FXO Gateway
    That looks all ok.

    So what does not work?

    External Number (PSTN line number, e.g. 22461000) : Put any number there does not care, it is for your purposes only.

    Internal Number (Use different range as extension range): 10000
    If you successfully register it will say something like sip:10000@192.168.0.199. But in your case it states sip:192.168.0.199 so it looks like the line it tries to register on in your ATA is blank.

    Allow outbound calls on this line: Make sure this is ticked
    Answer incoming calls on this line : make sure this is ticked
    Answer after : set to 1

    Authentication ID: This MUST match your Username for your LINE ACCOUNT on your ATA.

    Password: This MUST match your password on your LINE ACCOUNT

    I believe you find this in your manual on page 15.

    So I would remove the gateway from 3xc and start from scratch making sure that the Authentication ID and Password are correct when you set it up.

    Hope this helps
     

Share This Page