Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Mikrotik SIP ALG

Discussion in '3CX Phone System - General' started by davidm85, Jan 30, 2018.

Thread Status:
Not open for further replies.
  1. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    I recently installed a new router a Mikrotik Hex.

    When I first ran the 'firewall checker' sip alg was not detected.
    But now it states 'failed', although the sip alg is deactivated on the router.

    What could cause this problem?

    thanks
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    40
  3. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,530
    Likes Received:
    298
    I had intermittent test issues with the Firewall Tester using a Mikrotik. My system works just fine. I do see they do not have an outbound SNAT on the Mikrotik instructions but I have found my system to be more stable with it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    thx for the replies.

    I've checked all the setting from the 3CX doc but everything seems fine.

    The error about the sip alg test keeps comming up.

    the strange part is that with the first run, everything was ok
     
  5. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
  6. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    thx @Brian Cross but when I run the tool, I get an access denied message (run the tool as administrator)

    upload_2018-1-31_9-0-26.png
     
  7. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
    Hmm local firewall on or something?
     
  8. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    the windows firewall is off,
    and the mikrotek router has factory settings, with just the 3CX settings
     
  9. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,375
    Likes Received:
    84
    I
    T could be that it can't bind to port 5060 because something else is using it. If you ran this on the 3CX Server, for sure 5060 is being used by 3CX. Stop all 3CX services and try running this tool again (as admin), maybe this helps...
     
  10. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    Hi,

    this was indeed the problem, when i shutdown the services and disable the 5060 udp and tcp rule, the test works.

    I also had a conversation with one of your colleagues, and the sip alg test works in 3CX when i disable the 5060 - udp rule in the router. Strange behavior, because all settings are taken from the 3CX mikrotik guide
     
  11. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
    Makes sense I usually run it on a workstation on the network not on off the 3cx server. So what was the verdict SIP ALG off?
     
  12. davidm85

    Joined:
    Jan 15, 2018
    Messages:
    13
    Likes Received:
    0
    With the help of the mikrotik forum I managed to solve the issue, I had to add a setting to the router firewall settings for 3CX protocols.
    I had to set incoming interface= wan interface.
     
  13. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,301
    Likes Received:
    530
    Glad to see the issue has been resolved and thank you for updating the thread with your solution
     
Thread Status:
Not open for further replies.