Minimum requirements for Firmware Updates

Discussion in '3CX Phone System - General' started by Kevin Burns, Apr 14, 2017.

Thread Status:
Not open for further replies.
  1. Kevin Burns

    Joined:
    Apr 3, 2017
    Messages:
    43
    Likes Received:
    2
    I am upgrading the phone system from version 14 to 15. Does it matter what firmware Yealink phones starts a or will 3CX upgrade any older firmware instance to its newest version.

    Also related,
    I had updated a Yealink T23G phone to its newest firmware which is 44.80.0.70 and in 3CX it says that that firmware is unsupported. It doesn't allow me to upgrade the firmware from within the management console.

    For example,
    I have a T46G with firmware at version 28.80.0.60 and a T48G at version 35.73.0.40. Will I have to update these firmware's to a newer version before 3cx is able to recognize them and run its own firmware upgrade or will 3CX recognize them and upgrade them without going into the IP of each phone?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,443
    Likes Received:
    282
    Hello @Kevin Burns

    Please note that the management console will not allow you to downgrade the firmware as your phone has a higher firmware that the supported one which is 44.81.0.60/61 for the Yealink T23g. You should be able to upgrade the rest of the phones with no issues through the management console.
     
  3. Kevin Burns

    Joined:
    Apr 3, 2017
    Messages:
    43
    Likes Received:
    2
    Thanks so much!
    Just to make sure I 100% understand. Every older firmware will be recognized and is upgradable? For at least Yealink phones? correct?
     
  4. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    736
    Likes Received:
    113
    @Kevin Burns

    Just do the upgrade. One of two things will happen. Either it will allow you to upgrade via the console or it won't. If it won't, you'll have to upgrade the firmware manually which is what you would have to do if the answer comes back as 'you have to be on xxx firmware before you upgrade'. So you aren't really saving yourself anything but following this line of questioning. But yes, to re-iterate what YiannisH_3CX already said:

    You should be able to upgrade the rest of the phones with no issues through the management console
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.