Missing: call info, recordings, voicemails

Discussion in 'iOS' started by integrity2, Sep 8, 2013.

Thread Status:
Not open for further replies.
  1. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    I'm on 3cx 12 and using the 3cx 12 ios app. If I record a phone call it doesn't show in the recordings of the app - missed, received, all call info is come rely blank - as is voicemails.

    Are there some settings or firewall rules I am missing somewhere?

    Thanks!
     
  2. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    Edit with required details
    -------------------------------------------------------
    Phone Model: [iPhone]
    Generation: [4s]
    Firmware Version: [6.1.3]
    Jailbreak: [NO]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone]
    Contacts: [Local]
    Connection: [3G and wifi]
    Server: [External and external]
     
  3. sraoof

    Joined:
    Dec 26, 2012
    Messages:
    3
    Likes Received:
    0
    im having the same issue. anyone have any info on how to correct this?
     
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,198
    Likes Received:
    79
    top left "CTI Connection"
    bottom left "SIP Connection"

    u need to have the port 5000 for http and 5001 for https frwd to the pbx.
    however make sure ur https connection is correctly formulated (https://FQDN:5001)
    iOS does not fall back to http when https is not connecting!

    & You must use provisioning (pnp or via e-mail to connect to the cti interface)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    Ok, if you installed using http option instead of the https option, is that going to cause a problem? Is the ios app still going to use https?

    Is that cti and sip connection in the 3cx extension configuration?

    Thanks for the response!
     
  6. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,198
    Likes Received:
    79
    no, then the iphone will use the http connection. in case you have installed pbx with https option (and in the config file to the phone we find on ios https and http) we only use on ios http. android and windows behave here different and fall back after a try to https to http...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    Does it matter if the SSL certificate is self signed (the default SSL Cert that was installed with the system)?
     
  8. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    Sorry, can you elaborate on what you mean by this:
     
  9. CvdPost

    Joined:
    Sep 28, 2013
    Messages:
    4
    Likes Received:
    0
    I am having the same issue with iPhone 5s (iOS 7) and latest 3CX System 12 software - not connecting, no presence etc, but show "On Hook" and calls can be made. Interestingly enough, an iPad with the same client (latest 3CX iOS client, iOS 7) configured the same, is NOT having the issue and connecting and showing presence (Windows clients are functioning correctly too). All devices are being used on a LAN.

    Can you please elaborate and explain where these settings need to be made. However in my case, I don't understand why one iOS device (iPad) is working and 2 iPhone 5s are not. Thanks.
     
  10. CvdPost

    Joined:
    Sep 28, 2013
    Messages:
    4
    Likes Received:
    0
    Got the iPhones working by editing the config file that is sent out with the email when creating a new extension (changing http to https etc etc). Still interested to know why the iPad worked without modification, yet the iPhones did not.
     
  11. Felixcat

    Joined:
    Sep 16, 2011
    Messages:
    12
    Likes Received:
    0
    Hi CvdPost,
    I'm having the same problem too - would you be kind enough to tell me exactly which addresses you changed?
    Thanks in advance,
    Steve
     
  12. CvdPost

    Joined:
    Sep 28, 2013
    Messages:
    4
    Likes Received:
    0
    If I remember correctly I changed the "MyPhoneServerLocalAddr" and "MyPhoneServerLocalSSLAddr" to be https with a port of 5001 from http and 5000. Now I have Local and Public SSL and non-SSL all https and port 5001. Where x.x.x.x is the internal LAN IP address and y.y.y.y the External IP from the ISP.

    <ProvLink>https://x.x.x.x:5001/provisioning/fzv1o8akzs/TcxProvFiles/3cxProv_xxxxxxxxxx_123.xml</ProvLink>
    <MyPhoneServerLocalAddr>https://x.x.x.x:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalAddr>
    <MyPhoneServerPublicAddr>https://y.y.y.y:5001/MyPhone/MPWebService.asmx</MyPhoneServerPublicAddr>
    <MyPhoneServerLocalSSLAddr>https://x.x.x.x:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalSSLAddr>
    <MyPhoneServerPublicSSLAddr>https://y.y.y.y:5001/MyPhone/MPWebService.asmx</MyPhoneServerPublicSSLAddr>

    I am still experimenting so may be able to refine this, but it may be a start. I am not using name resolution but rather hard-coding in the IPs as I work through it. Compare the above to the standard file settings.

    Hope that helps.
    CvdPost
     
  13. Felixcat

    Joined:
    Sep 16, 2011
    Messages:
    12
    Likes Received:
    0
    Hi CvdPost,

    Many thanks for your help - that has done the trick - all working now!

    Thanks again,
    Kind regards,
    Steve
     
  14. CvdPost

    Joined:
    Sep 28, 2013
    Messages:
    4
    Likes Received:
    0
    Glad I could help.

    I am sure I am going to need lots of help from others as I work through this great product - so please continue to post answers to our questions out there - or anything anyone learns that may be useful to others . I learn something everyday, it is an awesome product with fantastic features.

    CvdPost
     
  15. chlliew

    Joined:
    Mar 4, 2014
    Messages:
    8
    Likes Received:
    0
    Can we setup the setting to automatic disable that https setting?
     
  16. alexdelyon

    Joined:
    Jul 2, 2010
    Messages:
    5
    Likes Received:
    0

    Hi,
    I am having the same issue with iPhone 5s (iOS 7) and latest 3CX System 12 software.

    Where do we apply those changes ? we have to open and edit the config file that is sent out with the email ? If yes how do we open it ? it's a .3cxconfig !

    thank you !
     
  17. alexdelyon

    Joined:
    Jul 2, 2010
    Messages:
    5
    Likes Received:
    0
    Nobody know how to do this ?
     
  18. alexdelyon

    Joined:
    Jul 2, 2010
    Messages:
    5
    Likes Received:
    0
    Excuse me but is there somebody on this forum ???

    o_O
     
  19. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,956
    Likes Received:
    180
    alexdelyon,
    the config file is a simple text file that can be edited with notepad or other text edit program. do not use wordpad or word.

    but you should really try to find the root of the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. alexdelyon

    Joined:
    Jul 2, 2010
    Messages:
    5
    Likes Received:
    0
    Hello .

    My problem is solved !

    Yes the config file can be edited with notepad thank you !

    And my problem in the config file didn't came from the "https", i had just to change and put the good IP at the good place, and for this i just followed those explaination with x.x.x.x and y.y.y.y (I did not change the https from the original config file)


    Where x.x.x.x is the internal LAN IP address and y.y.y.y the External IP from the ISP :

    <ProvLink>https://x.x.x.x:5001/provisioning/fzv1o8akzs/TcxProvFiles/3cxProv_xxxxxxxxxx_123.xml</ProvLink>
    <MyPhoneServerLocalAddr>https://x.x.x.x:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalAddr>
    <MyPhoneServerPublicAddr>https://y.y.y.y:5001/MyPhone/MPWebService.asmx</MyPhoneServerPublicAddr>
    <MyPhoneServerLocalSSLAddr>https://x.x.x.x:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalSSLAddr>
    <MyPhoneServerPublicSSLAddr>https://y.y.y.y:5001/MyPhone/MPWebService.asmx</MyPhoneServerPublicSSLAddr>

    Thank's and good luck for all !
     
Thread Status:
Not open for further replies.